Fedora 34 KDE(guest) as a virtual machine , virt-manager (kubuntu 21.04 host), Resolution problems

How can we fix resolution problems in fedora 34 guest,
Auto resize doesn’t work.


  • libvirt-daemon 7.0.0
  • libvirt-clients 7.0.0
  • qemu 1:5.2
  • virt-manager 1:3.2.0-3

I have checked
View> Scale display> Auto rezise VM with window
(In Host) I had added my user account to libvirt group following this tutorial

Display spice, type: Spice server
Video VGA

host resolution: 1920x1080

Have you installed spice-vdagent in the guest.

1 Like

Yes I do. spice-vdagent version 0.21.0-3.fc34 on guest

Have you tried an X11 session?

yes , I was in wayland , now in xorg x11 session, in both the same problem.

The solution was switch VIDEO from VGA to QXL


QXL should work but performance is relatively poor if you need to anything graphics related in the VM. The virtio option should be the best choice in most cases.

For the record, QXL doesn’t work either. And it’s much worse than virtio, performance-wise, and its choice of (fixed) resolutions is much more conservative, despite the usual QXL memory tune-up (https://chowdera.com/2021/05/20210507085710042x.html). The biggest resolution I could get with virtio was 5120×2160, which fits my monitor horizontally, but is still too small vertically. QXL seems to be limited to 4k or less, unfortunately. And there is no automatic resizing for Fedora guests whatsoever.