Fedora 34 freeze at boot


I have a problem that is a bit beyond me.

I have an HP envy 13 ah0007nf with a Fedora 34 (i3wm spin) freshly installed.

Unfortunately I have a freeze (kernel panic?) on the login page (at boot).

To know more I configured the kernel boot with single option and removed the quiet option. The only error I get is “hp_wmi: query 0x4c returned error 0x6”. After some research I find https://github.com/torvalds/linux/blob/v5.11/drivers/platform/x86/hp-wmi.c

It seems that this bug is linked to a HPWMI_THERMAL_POLICY_QUERY request. Maybe the kernel communicates badly with the bios? I am on a 5.11 kernel.

I don’t know what else to do to fix this …

I thank you in advance.

1 Like

Your kernel is end-of life, unsupported, quite old, it’s actually the kernel it was released with in April 2021.


Update your system first and check if the problem persists

1 Like

I don’t know how I can update the system if I can’t boot …

Oh, I see, that is difficult. Unfortunately, there aren’t any newer iso images (with more recent kernels).

I would re-install from the netinstall (Everything) image since that downloads the newest packages and should leave you with a fully updated system (again, this should be Fedora’s default install for many reasons).


Alternatively, try Fedora Linux 35, it’s in beta stage now and should be released in two weeks time.

I reinstalled via the iso you provided. Still the same problem … This is a really persistent problem on this computer, I had the same one a year ago when I tried to install Linux. I finally gave up and stayed on Windows… I even tried with other distribution but no success, at the same time the error seems to come from the Kernel.

Maybe I need to buy a new laptop. Not an HP this time…

Is your BIOS firmware up to date?

Yes, that was the first thing that came to my mind. I put the latest BIOS update provided by HP (August 2021).

3 posts were split to a new topic: Freeze after editing .bash_rc

I tried with the least “exotic” option in the bios, disabling virtualization and secure boot. Still the same problem …

For the problems related to the configuration of the .bash_profile I really don’t see how it could happen, I just installed Fedora and at the first boot the computer freezes. It even freezes when I boot into single mode. Thanks anyway for these answers but I think I give up on this computer with Linux, too many problems and not enough time to fix it all.

I have the same problem。 And
I am currently installed dual system (windows 11&fedora 35) on HP notebook(hp laptop 14s-cr2005Tu).
If I shutdown hp hook, next grub2 boot first boot fedora 35 , system will freeze when i login in or not login in just a little minite.
now I workaroud by this step:
IF I shutdown hp book. next grub2 boot need first boot windows then reboot into fedora 35 ,every thing is ok.

I had try update bios and change kernel nvme and so on , but all not work.

In the recent weeks, several users had comparable problems (including problems related to freeze after suspend, or not working suspend, which can all be another manifests of the same error).







At first, update your Fedora 35 to the current kernel: 5.15.6. This already solved the issue for some.

Another solution that helped for some was acpitool (see the threads I mentioned above). Alternatively, if you have proprietary drivers (e.g. nvidia/ati), deactivate them and try if the problem persists with nouveau (also: review the threads above).

If all this does not work for you, open a new thread because this one is about Fedora 34 and also a bit outdated.


actually it’s seems to be happening again i don’t know why, maybe last few updates brings the issue back. i remember there was an update for Mesa Driver, i don’t know if it’s related

Thanks for the answer.
I’ll try other solutions in my spare time.