System freeze on login on workstation 37

Everything was smooth last night but when I started my laptop today it is freezing in login screen. Either it freezes or display start to glitch with grey grains or red lines like below

I can’t even login.

I didn’t update anything which shall cause this issue. But still I am stuck. Also noticed 2 different kernel version in grub. I can’t be sure if I saw 2 different fedora kernel version for first time. Cuz I never focused there untill today.

Sorry I couldn’t attach any logs as I said I cannot login. If
There a way to access terminal before login or to take logs kindly share.

It’s hp laptop with Intel i3 7 gen processor (adding if it helps)

You could try to use the second row of Fedora Linux kernel on grub list (6.0.7-301).

May be it because the Preference on the Gnome Sofware are set on Automatic Update. That is why you got Fedora Linux 6.1.10-200 linux kernel.

None of them is working. It’s just windows working fine

Update: I removed fedora wiped all partitions of fedora and tried installing fedora 38. Still fasting same issue while installing. Although fedora live boot with minimalistic gui works fine

I want to install fresh fedora but can’t. Kindly Help

Same system freezing with red lines on screen

Have you tried the “troubleshooting” option from the live media grub boot, which has a basic graphics mode for doing the install? As I recall the options are basically “boot”, “test & boot”, and “troubleshoot”

That looks like it may be trying to boot but cannot properly control the video and user IO.

That does not appear to be a login screen, but the first screen displayed during boot from the live (installer) media.

Yeah basic graphics mode works fine but why is fedora 38 live installer behaving like?

Yes, press ctrl+alt+F5 to access tty5 and login there for a CLI session.

Edit: use tty5

Was not working tried, system freezed before I could do this

My bad, tty3 is used for the graphic display, try ctrl+alt+F5 for tty5.

But the thing is laptop freezes before that

It seems that something is going wrong when the display server starts; I’d hazard a guess that it’s specific to Wayland as the simpler installer still uses (correct me if I’m wrong on this).

Does this laptop have a separate video card/chipset and if so which brand is it? Nvida? AMD? Or integrated Intel graphics?

I am not sure about that but this also happens with login screen also. It work fine in boot with basic gui option on live fedora

There is no dedicated graphics card. It’s a simple budget laptop with integrated graphics with i3 7gen.

If you able to install Fedora Linux, you could install it again. But when you finished the installation and the display displaying the grub list as your first post (that have kernel version list), press e. It will bring you to grub parameters.

Move your cursor to line right after rhgb quiet then add <space> then acpi=off. After that press Ctrl + x to boot using current setting.

If you are able to login, you could make permanent above grub parameter by editing file /etc/default/grub with any editor as root, then find line GRUB_CMDLINE_LINUX="rhgb quiet" than add <space> acpi=off (it will be like GRUB_CMDLINE_LINUX="rhgb quiet acpi=off"), save it.

After that run sudo grub2-mkconfig -o /etc/grub2-efi.cfg.

Thanks can you also please shed light on what these steps do. I have reinstalled fedora and it’s working fine as of now. But I want to know the reason bcz it may happen in future too

I tried to find any bugs related to your processor on kernel bugzilla (any Intel 7th gen). The recent one and I think is related to your case is about acpi. You could find it here.