Fedora 34 - AAC codec

I’ve recently updated to f34 and now i’m unable to get sound playback with (AAC-LC) encoded videofiles. I cannot use ffmpeg or HandBrake to convert it either. HandBrake-gui throws the following error:

encavcodecaudio: avcodec_send_frame failed

When I ffprobe a file it throws the following message:

Assuming an incorrectly encoded 7.1 channel layout instead of a spec-compliant 7.1(wide) layout, use -strict 1 to decode according to the specification instead.

VLC throws the following error:
libmp3lame @ 0x7f4b184f8900] Specified channel layout ‘7.0’ is not supported

All the gstreamer (good bad ugly libav free) are installed and it worked before the upgrade. I also tried to revert to pulseaudo but it did not help. Totem (which uses gstreamer instead of ffmpeg ?) works fine.

Can someone put me in the right path in how-to debug this issue ? Thanks.

1 Like

All these packages are from RPM Fusion, right? Perhaps asking on their mailing list directly may help?


1 Like

ffmpeg and HandBrake are indeed, I did not think of that.
I’m going to ask it there, thanks.

1 Like

Thanks, please do let us know if you find the issue and a solution.

Please do let us know if you find a solution. I tried a clean install. I do not get an error, but Handbrake does not encode sound with the video.

Can you share the source file or at least a piece of it? It looks like you’re trying to encode from 7.1-channel audio using libmp3lame, which doesn’t support this. Can you post HandBrake encode attempt log, too? Your ffmpeg command line and log would help as well.

1 Like


Thanks for the replies. I haven’t found the issue yet. How can I shrink the video without re-encoding ? If i use handbrake with the same settings as the video the audio-track disappears.

My full handbrake log:
My ffmpeg log:


I solved this issue by removing the rpmfusion handbrake packages, which are apparently complied against some incorrect libraries, and installed the flatpak which is provided by the HandBrake team. Worked perfectly with default settings.

1 Like

hi @mo64 . Welcome to the forum. Please take a look at the introductory posts in the #start-here category if you’ve not had a chance to do so yet.

I don’t see a bug filed at RPM Fusion about this. Could someone file one please so that the maintainer could look into it?


This is a known issue when unpatched HandBrake 1.3.3 is linked with FFmpeg 4.4. There was a bug filed about it and It’s fixed in RPM Fusion already (update to HandBrake-1.3.3-12).

1 Like

As mentioned, this is a bug in HandBrake 1.3.3 (which is one year old!). We fixed it in RPM Fusion already. Try dnf --enablerepo=rpmfusion-free-updates-testing update HandBrake.

1 Like