Fedora 33 upgrade breaks snap app

I just upgraded from fedora 32 to fedora 33 via the command line. When I tried starting the urban-terror snap, it complained of no opengl support specifically:
can’t load libGL.so.1 from /etc/ld.so.conf or current dir No dynamic GL support in current video driver.
It was all working before the upgrade.
Many thanks in Advance

1 Like

Is this snap from the Fedora repositories? Could you please provide more information: what version of snap is this, for example?

If it is from the Fedora repositories, a bug should be filed on Bugzilla so that the maintainer can look into the issue. (Package maintainers do not monitor the many support channels) If this is not from the repositories, the people you are getting snap from need to be notified.

1 Like

I am in discussion with the package maintainer on snapcraft forums. It is not a fedora package (does Fedora maintain any snaps at all?), but the problem seems to be due to some change between Fedora 32 and Fedora 33.
I created a live usb with persistent storage of Fedora 33, and installed snapd and then installed the urban-terror snap, and obtained the same result.044a996fb38c64e2ac256dbb92285a6108b00f63.jpeg

I guess that other opengl snaps may be affected also.

1 Like

It seems you are missing a dependency:

sudo dnf install libglvnd-glx.{i686,x86_64}

No, libglvnd-glx is already installed.
The problem turns out to be that the latest version of Gnome used by Fedora 33 doesn’t allow access to the X11 anonymous socket, where the version of Gnome used by Fedora 32 does.
This is a really big problem, as a change to use the anonymous socket has already been pushed to Gnome on Ubuntu, and as far as I am concerned, the anonymous socket is a massive security flaw.
I use the wayland desktop with the snap purely because if I run urban-terror as a native app, it has to be run using X11 and then hackers have a field day with the anonymous socket and interfere with keyboard and mouse communication, as well as worse things like attempts to raise privileges.
Even with the snap running on a wayland desktop, the anonymous socket was recently used on my Fedora 32 to make a gksu request to raise privileges.
So, I am stuck. It looks like no more urban-terror or any other game/app that requires an anonymous socket to connect to the window manager, as I don’t want to use an x11 based window manager.