Fedora 33: NVIDIA kernel module missing. Falling back to nouveau


I am a newbie and have just installed the current Fedora 33 Workstation beta (33_Beta-1.3)

But the detection of the USB boot stick and the installation only works if I have disabled “Secure Boot” on my PC.

Then I did this:

  1. GNOME Software → Updates

  2. I have all selected. Then everything was installed after the download and I restarted the PC.
    The current kernel version is: kernel-5.8.16-300.fc33

  3. Now I reopen GNOME Software → Software Repositories → RPM Fusion for Fedora 33 - Nonfree - NVIDIA Driver → Enable…

  4. Now I open the search in GNOME Software and type “Nvidia” and I have just selected and installed this: NVIDIA Linux Graphics Driver

  5. Restarts PC and it always shows me this message:
    NVIDIA kernel module missing. Falling back to nouveau

  6. What now? What should I do? I am a newbie and want it to be solved easily. Why does it not work? My PC is using a NVIDIA GeForce GTX 650.

Can you also reproduce it? You have to do exactly the same as I just freshly install the current Fedora 33 beta and do exactly what I wrote here. It is 100% reproducible on my PC.

1 Like

I almost never use Gnome Software for anything except as an indicator updates are available; try installing the NVIDIA driver using the command line tips from the RPM Fusion homepage. Always work for me.


Thanks for your answer.

Can you explain step by step what exactly I need to do? I don’t know, because I have always used Windows 8.1 and installed the Nvidia drivers simply by using an executable file (.exe).

I hope it is easy and fast, because I have little experience with Terminal.

I would find it better if this problem could be solved. That means what I just wrote has to work so that beginners can use the Nvidia drivers easily and quickly without problems from GNOME Software.

Can the Fedora developers fix it now for the Fedora 33 Workstation final version?

Then I will test it again to see if it worked from GNOME Software.

I have used Gnome Software to install Nvidia proprietary driver in the past and it worked fine. In fact, I’m on fedora 33 right now and just tried it, and it worked fine as well (I just prefer not use the proprietary driver as I don’t game on this laptop. If you don’t as well, you can just stick with noveau driver).

Since that has not worked for you, I suggest you do it manually in the terminal.
Check out Configuration - RPM Fusion to learn how to enable the rpmfusion nonfree repository (you might as well enable the free one too).
Then follow the instructions to install the Nvidia driver at Howto/NVIDIA - RPM Fusion .

Good luck!

1 Like