Fedora 33 + new Nvidia driver = modinfo: ERROR: Module nvidia not found

Hi everyone,

After following RPM guide, I’m still not able to install the Nvidia.
I ran the following commands:

sudo dnf update -y # and reboot if you are not on the latest kernel
sudo dnf install -y akmod-nvidia # rhel/centos users can use kmod-nvidia instead
sudo dnf install -y xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support
sudo dnf install -y xorg-x11-drv-nvidia-cuda-libs
sudo dnf install -y vdpauinfo libva-vdpau-driver libva-utils
sudo dnf install -y vulkan
modinfo -F version nvidia

The same answer all the time: modinfo: ERROR: Module nvidia not found.

And of course it doesn’t boot using the proprietary driver, but nouveau.

Kernel: 5.9.16-200.fc33.x86_64
Nvidia driver: latest (460)
Laptop: Asus G14 + RTX 2060

Appreciate any help… thanks

Do you have the akmods, kernel-devel and kernel-headers packages installed?

Please post the output of

sudo dnf list installed '*nvidia*' akmods kernel-devel kernel-headers


sudo inxi -Gxx

Hello, thank you for the support. I was able to solve after disabling asusd.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.