Fedora 32 workstation sharing screen not working after upgrade from fedora 31

fedora30kvm, Thank you for the x11vnc solution. Does it work for remote controlling the local screen? It is because I shall not only use the fedora computer remotely, but also locally use the same computer. So I need the vnc to connect to the local session.

Hi fuguhu!
x11vnc can be controlled the local screen.
Local session is for real machine ?

I can use to both remote and locally at the same instant,
screen lock on/off work, session not close and not show black screen.
however, i connect to remote host only IP address, i dont check the domain name.

(Sorry, in poor English…

Hello fedora30kvm,
My English is also not good.
You are so kind to help me. Thank you very much!
Finally, I use x11vnc with xrdp because x11vnc does not encrypt the connection the same way as the default screen sharing.

For anyone who need a secured remote solution in Fedora32, here are the steps:
dnf install x11vnc xrdp
systemctl enable xrdp
systemctl start xrdp
x11vnc -storepasswd mypassword /home/user/.vnc/passwd (replace user with your user name)
Create an autostart script at /home/user/.config/autostart/x11vnc.desktop . Desktop files in this directory are executed as soon as the GUI loads.


[Desktop Entry]
Name=X11VNC Server
Comment=Share this desktop by VNC
Exec=x11vnc -forever -shared -display :0 -rfbauth /home/user/.vnc/passwd

Then edit /etc/xrdp/xrdp.ini and make sure it contains at least the following:

[globals] bitmap_cache=yes bitmap_compression=yes port=3389 crypt_level=high channel_code=1 max_bpp=24 [xrdp1] name=Remote Desktop lib=libvnc.so username=ask password=ask ip= port=5900

Restart xrdp for the changes to take effect:

/etc/init.d/xrdp restart

Remember if you rebooted your machine, you need to login once to enable x11vnc. This is the same case if you use the builtin screen sharing function. And make sure you are using the Xorg session instead of the default Wayland session.


update now, fix this bug!!
These package is gnome-shell-3.36.3-3, gnome-remote-desktop-0.1.8-2, gnome-control-center-filesystem-3.36.3-1.

1 Like

is there any official bug-report that screen sharing is no more working in fedora 32?

Is there any solution beside installing x11vnc?


@ fedora30kvm what you mean with “update now, fix this bug!!” ??
i have exactly the same versions installed but screen sharing still not possible to activate

has someone an info from redhat/fedora about this issue?

What is the fedora recommended way of screen sharing(without using cloud tools like jitsi or hangouts)?

For me it looks like nobody from redhat/fedora is aware of this issue or working on it !?

So how do we get them to be aware of it?

Works for me.


  • Fedora 32
  • remmina / remotely / vinagre


  • Fedora 32
  • gnome-remote-desktop
  • GNOME + Wayland / Xorg

Server setup


sudo dnf install gnome-remote-desktop


sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload

Settings > Sharing > Screen Sharing:

  • Allow connections to control the screen
  • Require a password
    Password: [password]
  • Networks > [Connection name]

If you can’t see the Screen Sharing option, try to log in with Wayland.
It should work with Xorg as well once you activate it from Wayland.

1 Like

sory my poor my english. :sweat:

I now check.
for me, wok well on both Fedora 32 Clean VM and upgrade Fedora31 to Fedora32 real machine.

However, use this on home LAN, on WAN I don’t test…
I guess check update all package and gsettings encryption.

sudo dnf update --refresh

and Login your account on your machine, GNOME setting ,then below.

gsettings set org.gnome.desktop.remote-desktop.vnc encryption "['none']"

Please Caution!, not Vino, it’s vnc! vino is Ubuntu case.


as vgaetera said

sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload

perhaps, cannot to vnc on wayland, try X11!

I try cleaninstall F32 VM, connect to it, VNC client crash.
However, gnome remote desktop work fine on my real machine.

My recommend is X11vnc.
how to setup I write above.


the question is NOT about opening any session with remote desktop or vnc…this is working

The question is about REAL SCREEN SHARING.
Means user A is logged in and shares the screen…user b(admin) connects to the screen of user A…

How this is possible with fedora 32??


This is confusing.
Was there any other way prior Fedora 32?
GNOME provides a method to share the current session via VNC using:

the problem is that this option is no more working in Fedora 32 as its not possible to switch this option to ON

on X11? once, on Wayland switch this option to ON.

Well, as I mentioned above, it still works for me with both Wayland and Xorg.

Check your configuration:

sudo firewall-cmd --list-all
ss -l -n -p -t | grep -e gnome-remote
gsettings list-recursively org.gnome.desktop.remote-desktop.vnc
gsettings list-recursively org.gnome.settings-daemon.plugins.sharing.service:/org/gnome/settings-daemon/plugins/sharing/gnome-remote-desktop/
nmcli connection show

Sorry, my lack of talk, work fine both Xorg and Wayland.

Screen sharing in GNOME setting tool can’t switch to ON on Xorg.
Once login to Wayland, setting switch to ON, then login to Xorg.
However, can’t switch to both ON and OFF,
can connect to screen sharing.

edit: X11→Xorg

logging in via Wayland sufficed to make it work for me.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.