Fedora 32 workstation sharing screen not working after upgrade from fedora 31


I just upgrade from fedora-31 workstation to fedora-32 and now I’m unable to activate from the setting the screen sharing. When I click on the "Settings → Sharing → screen sharing ", I’m unable to activate the sharing. Sharing files, media and remote login wok.

Any idea?



I am having the same problem after Fedora 31 to Fedora 32 system upgrade.

I also had this problem with new installation of Fedora 32, after I configured Screen Sharing.

For a while it seemed to work, but after disabling encryption (vino/vnc encryption, in order to be able to connect from less secure VNC clients), Screen Sharing didn’t worked anymore (in fact, UltraVNC client seemed to start connection, but the password “was always” wrong besides changing and matching at both server and client) and it shows disabled at Settings.



I am having the same issue, screen sharing won’t work on Fedora 32.
If it helps, when opening sharing settings using gnome-control-center -v from the terminal, I get this message sharing-cc-panel: WARNING: couldn't list networks: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Invalid service name 'vino-server'

I’m using Xorg, maybe Wayland doesn’t have this issue?


I end up to use x11vnc! Works well but have issue to make it running at boot using upstart.


Thank you! But I still think this bug should be resolved :confused: I’ll try x11vnc :wink:

For me it helped to run systemctl --user start vino-server

Hello! I have a similar problem.
I have been using screen sharing in a few versions of fedora. After upgrading from 31 to 32, I cannot enable screen sharing in Xorg session (it just cannot be set to enabled from setting). Then I switch to wayland and I can enable screen sharing now. Because my fedora is behind the broadband router, I have enabled port forwarding and it worked in all previous versions of fedora. However, fedora32 has some problems described below:

  1. I can connect to it using from LAN without problem
  2. Before I tried to lock screen, I can connect from WAN without problem.
  3. After some hours, when I am connecting from outside, it asks me to enter password. If I enter a correct password, it shows me a black screen with a small cross as the mouse cursor.
  4. When I move the mouse or type something, my fedora does see the mouse moving and it displays the text in my local screen. But from the computer I am remoting from, I just show a black screen with small cross mouse cursor.

Because I use screen sharing frequently, It will be nice if some gurus can help me. Thank you.

1 Like

I think the problem is related to lock screen.
In a fresh reboot, I can connect to screen sharing from WAN. But after I have lock the screen once, even if I unlocked the screen locally, connecting from WAN resulted in black screen with a small cross cursor…

What I can do now is to reboot my fedora 32 then vnc to it immediately then keep the vnc session there. Doing so I can survive even if screen lock has been activated. Hope there will be a fix soon. Thank you.

1 Like

the same problem my Fedora32.
I’m so confused too.

I use x11vnc.(not wayland)
It’s a rough process, as below.

sudo dnf install x11vnc
mkdir ~/.x11vnc
x11vnc -storepasswd ~/.x11vnc/passwd
(password twice)
x11vnc -noxdamage -many -display :0 -auth /var/run/gdm/$(sudo ls /var/run/gdm | grep $(whoami))/database -forever -bg -rfbport 5901

vnc viewer to connect IP-Address:5901
(example above N=0)

more detail, see https://wiki.archlinux.org/index.php/X11vnc

edit: commnd add port

fedora30kvm, Thank you for the x11vnc solution. Does it work for remote controlling the local screen? It is because I shall not only use the fedora computer remotely, but also locally use the same computer. So I need the vnc to connect to the local session.

Hi fuguhu!
x11vnc can be controlled the local screen.
Local session is for real machine ?

I can use to both remote and locally at the same instant,
screen lock on/off work, session not close and not show black screen.
however, i connect to remote host only IP address, i dont check the domain name.

(Sorry, in poor English…

Hello fedora30kvm,
My English is also not good.
You are so kind to help me. Thank you very much!
Finally, I use x11vnc with xrdp because x11vnc does not encrypt the connection the same way as the default screen sharing.

For anyone who need a secured remote solution in Fedora32, here are the steps:
dnf install x11vnc xrdp
systemctl enable xrdp
systemctl start xrdp
x11vnc -storepasswd mypassword /home/user/.vnc/passwd (replace user with your user name)
Create an autostart script at /home/user/.config/autostart/x11vnc.desktop . Desktop files in this directory are executed as soon as the GUI loads.


[Desktop Entry]
Name=X11VNC Server
Comment=Share this desktop by VNC
Exec=x11vnc -forever -shared -display :0 -rfbauth /home/user/.vnc/passwd

Then edit /etc/xrdp/xrdp.ini and make sure it contains at least the following:

[globals] bitmap_cache=yes bitmap_compression=yes port=3389 crypt_level=high channel_code=1 max_bpp=24 [xrdp1] name=Remote Desktop lib=libvnc.so username=ask password=ask ip= port=5900

Restart xrdp for the changes to take effect:

/etc/init.d/xrdp restart

Remember if you rebooted your machine, you need to login once to enable x11vnc. This is the same case if you use the builtin screen sharing function. And make sure you are using the Xorg session instead of the default Wayland session.


update now, fix this bug!!
These package is gnome-shell-3.36.3-3, gnome-remote-desktop-0.1.8-2, gnome-control-center-filesystem-3.36.3-1.

1 Like

is there any official bug-report that screen sharing is no more working in fedora 32?

Is there any solution beside installing x11vnc?


@ fedora30kvm what you mean with “update now, fix this bug!!” ??
i have exactly the same versions installed but screen sharing still not possible to activate

has someone an info from redhat/fedora about this issue?

What is the fedora recommended way of screen sharing(without using cloud tools like jitsi or hangouts)?

For me it looks like nobody from redhat/fedora is aware of this issue or working on it !?

So how do we get them to be aware of it?

Works for me.


  • Fedora 32
  • remmina / remotely / vinagre


  • Fedora 32
  • gnome-remote-desktop
  • GNOME + Wayland / Xorg

Server setup


sudo dnf install gnome-remote-desktop


sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload

Settings > Sharing > Screen Sharing:

  • Allow connections to control the screen
  • Require a password
    Password: [password]
  • Networks > [Connection name]

If you can’t see the Screen Sharing option, try to log in with Wayland.
It should work with Xorg as well once you activate it from Wayland.

1 Like

sory my poor my english. :sweat:

I now check.
for me, wok well on both Fedora 32 Clean VM and upgrade Fedora31 to Fedora32 real machine.

However, use this on home LAN, on WAN I don’t test…
I guess check update all package and gsettings encryption.

sudo dnf update --refresh

and Login your account on your machine, GNOME setting ,then below.

gsettings set org.gnome.desktop.remote-desktop.vnc encryption "['none']"

Please Caution!, not Vino, it’s vnc! vino is Ubuntu case.


as vgaetera said

sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload