Fedora 32 sleep/suspend wake up issue

I updated my fedora 29 to fedora 32 recently, It seems I have problem with my laptop waking up from sleep/suspend. Nothing happens no matter which key I press. I have to reboot every time. I went through lot of articles but no help. It would be great if anyone can help, I am wasting time rebooting everyday. System info is as below

System: Host: abcabc Kernel: 5.7.9-200.fc32.x86_64 x86_64 bits: 64 Desktop: Gnome 3.36.4
Distro: Fedora release 32 (Thirty Two)
Machine: Type: Laptop System: Dell product: Latitude 5590 v: N/A
serial: <superuser/root required>
Mobo: Dell model: 0RMKK4 v: A00 serial: <superuser/root required> UEFI: Dell
v: 1.10.1 date: 07/19/2019
Battery: ID-1: BAT0 charge: 68.0 Wh condition: 68.0/68.0 Wh (100%)
CPU: Topology: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP
L2 cache: 8192 KiB
Speed: 800 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 800 2: 801 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800
Graphics: Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Device-2: NVIDIA GM108M [GeForce MX130] driver: nouveau v: kernel
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
Display: x11 server: Fedora Project X.org 1.20.8 driver: modesetting
unloaded: fbdev,vesa resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.3
Audio: Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.7.9-200.fc32.x86_64
Network: Device-1: Intel Ethernet I219-LM driver: e1000e
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: 00:0a:95:9d:68:16
Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
driver: ath10k_pci
IF: wlp2s0 state: up mac: 00:1b:44:11:3a:b7
Device-3: Qualcomm Atheros type: USB driver: btusb
Drives: Local Storage: total: 238.47 GiB used: 74.78 GiB (31.4%)
ID-1: /dev/sda vendor: Samsung model: SSD PM871b M.2 2280 256GB size: 238.47 GiB
RAID: Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
Partition: ID-1: / size: 48.97 GiB used: 17.39 GiB (35.5%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 975.9 MiB used: 138.1 MiB (14.2%) fs: ext4 dev: /dev/sda2
ID-3: /home size: 175.63 GiB used: 57.25 GiB (32.6%) fs: ext4 dev: /dev/dm-2
Swap: ID-1: swap-1 type: partition size: 7.83 GiB used: 0 KiB (0.0%) dev: /dev/dm-1
Sensors: System Temperatures: cpu: 44.0 C mobo: N/A gpu: nouveau temp: 25 C
Fan Speeds (RPM): cpu: 0
Info: Processes: 355 Uptime: 19m Memory: 31.22 GiB used: 3.75 GiB (12.0%) Shell: zsh
inxi: 3.1.03


Actually I just want to say that I am having the same problem with my Dell Precision 3350 with Quadro Card.

If I let the laptop suspend it will fail to wake up from suspend. I am on Wayland session with nouveau drivers.

However it seems to be it is not Fedora or Gnome Specific, I have been experiencing the same problem since a couple of months, on Mint Cinnamon, Elementary OS, Pop Os 19.10, 20.04, Manjaro KDE, with propriety or free graphics drivers.

It seems to be related to Quadro Card, as I have an old Dell Latidute which only has integrated Intel card, and the problem is not there with neither of above mentioned distros. Same with my wife’s Asus Laptop with MX 930 card (Elementary, Mint Cinnamon and now Manjaro KDE).

It seems to related to some Kernel update (also read about it somewhere) as I was using the same laptop since Setember 2019, and there we no issue. At the moment I was using either Mint or Elementary with 18.04 base, and the problem roughly appeared so when those distros upgraded to Ubuntu’s HWE kernel. And now, I am even having troubles to simply boot to 20.04 series (expect Pop OS and partially Mint, for which I can boot but it always stacks in the middle of install).

Sorry, not much of help, but just to let you know that you are not alone with the problem and some background that hopefully can help to resolve it.

for now, I just disabled suspend…

inxi -F --no-host
System:    Kernel: 5.7.10-201.fc32.x86_64 x86_64 bits: 64 Desktop: Gnome 3.36.4 Distro: Fedora release 32 (Thirty Two) 
Machine:   Type: Laptop System: Dell product: Precision 3530 v: N/A serial: <superuser/root required> 
           Mobo: Dell model: 0T36NT v: A00 serial: <superuser/root required> UEFI: Dell v: 1.12.0 date: 02/25/2020 
Battery:   ID-1: BAT0 charge: 61.2 Wh condition: 61.2/68.0 Wh (90%) 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP L2 cache: 9216 KiB 
           Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 901 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
           9: 900 10: 900 11: 900 12: 900 
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107GLM [Quadro P600 Mobile] driver: nouveau v: kernel 
           Device-3: Realtek Integrated Webcam_HD type: USB driver: uvcvideo 
           Display: wayland server: Fedora Project X.org 1.20.8 driver: nouveau note: display driver n/a - try sudo/root 
           resolution: 1: 2560x1440~60Hz 2: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.4 
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
           Sound Server: ALSA v: k5.7.10-201.fc32.x86_64 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
           IF: wlo1 state: up mac: 50:e0:85:37:36:6f 
           IF-ID-1: virbr0 state: down mac: 52:54:00:96:df:12 
           IF-ID-2: virbr0-nic state: down mac: 52:54:00:96:df:12 
Drives:    Local Storage: total: 953.87 GiB used: 381.67 GiB (40.0%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: RC100 size: 223.57 GiB 
           ID-2: /dev/nvme1n1 vendor: Samsung model: MZVLB1T0HALR-00000 size: 953.87 GiB 
Partition: ID-1: / size: 94.89 GiB used: 15.98 GiB (16.8%) fs: ext4 dev: /dev/nvme1n1p2 
           ID-2: /home size: 271.99 GiB used: 30.34 GiB (11.2%) fs: ext4 dev: /dev/nvme1n1p3 
Swap:      ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%) dev: /dev/nvme1n1p4 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: nouveau temp: 41 C 
           Fan Speeds (RPM): cpu: 2276 
Info:      Processes: 335 Uptime: 39m Memory: 31.15 GiB used: 3.79 GiB (12.2%) Shell: bash inxi: 3.1.03 

Hi @milangujarat, welcome to the Fedora community! :slight_smile:

If you’ve not had a chance yet, please look at the #start-here category. It has some very useful information on using the forum and tips on Fedora usage.

Now about your issue specifically, can you enlighten about to reason why you are not using a dedicated proprietary driver for your discrete card?

The thing that is common in your issue and that of @milangujarat is that both of you are using an Optimus-based device and with the sub-par okayish nouveau driver. Might be an indicator of what the problem is.

Thanks for the response. The thing is that I have been having the same problem with Pop Os and Mint, where I was using the propriety drives. (and PopOs sort of known for a good Nvidia support in their isos).

Additionally, my perception was that the problem occurred less often with nouveau than with propriety drives. In my earlier attempts, I have also set-up Nvidia Drives from RPM-Fusion Repo and the problem was still there.

P.S. I have distro-hopping because of this issue and also problems with Matlab installation, as I was not getting hardware acceleration in Fedora, but recently I was able to solve the Matlab related issue, so came back.

If you think the problem is really with open nvidia drivers, I am willing “to risk” my installation for another attempt. :slight_smile: Overall, I am quite new to Fedora, so I may missed some tricks…

Let us just say that Pop!_OS ships a version of their ISO with a preinstalled NVIDIA driver. :slightly_smiling_face:

True. But you seem to be running into problems with nouveau too, right?

Could you try switching into desktop environments with no graphics composition like MATE, XFCE etc to see if the problem still persist? It is still an arrow in the dark but a worthy try.

Well, that is true :slight_smile: I wrote and realized that was not entirely correct, however to be fair, they also have nice applet to change different Nvidia profiles and (at least for me) it nicely boots and installs, unlike Mint or Ubuntu, that have same base and Nvidia drivers in the iso (at least Mint).


Right, although the main reason sticking with nouveau is wayland and touch-pad gestures on the laptop.

Yes, I will give a try as soon as I got some time and will report back results. Actually, all the distros I have tried and installed were mostly with Gnome or Plasma. I was thinking GDM could be the cull-print, so I was using Manjaro KDE, but the problem occurred also there, as well as with LMDE, which used Slick/LightDM.

So thank you, I will try that option as well. :slight_smile:

I have some news:

So I installed Mint Cinnamon, after found out instructions in their website as to how overcome the issue I was experiencing.

The issue is still there, however I have noticed that when I suspend from GUI, e.g. start menu, I am able to recover, wake up from suspend (with propriety drivers), however, when I suspend with closing lid, then I am not able to recover.

I also set lid closure to locking screen, then closing and opening works just fine.
Furthermore, when lid closure is set to lock screen, and if I suspend from start menu and close the lid, than I can open and resume properly.

So the problemm seems to be to do how Dell handles lid opening (closing?), as in other scenarios I need to press the power button to wake from suspend, but in problematic scenario, it seems lid opening try to toggle power on (and the light on button becomes lit), but for some reason it does not able to properly boot.

So the solution seems to be to set lid close/open to nothing, and let the laptop sleep after some time. I’ll install Gnome back and try if this solution works.

meanwhile @milangujarat, you may try to toggle, OFF “suspend when laptop lid is closed” in Gnome Tweaks.

or edit /etc/systemd/logind.conf and uncomment/add HandleLidSwitch=ignore, option.

1 Like

The thing is Pop!_OS sticks to X11 due to its obligation of packing in and providing for NVIDIA. It does not step towards the advancements made in Wayland so its apples to oranges comparison here.

I was wondering why you used GDM even when using Plasma. (I mean, you might have used SDDM instead as it is a more sensible option)

That is what I would call a workaround. It is still not a fix. There is a compromise you have to make for the sleep (i.e. disabling the lid closing sleep). Let us keep the thread open so people who have faced issue regarding this can follow through and let you know.

I also have a similar suspend problem with Fedora 32 + NVIDIA driver.
Sometime when I resume a suspended session, X crash and I must re-login and start all my previous open applications
I have fill this bug on Bugzilla and attach to it some logs get from last crashed session.

Someone can help me to resolve this issue? or it’s better I post this problem on Fedora ML?
Many thanks

No, I was not clear. As I was trying different distros (and mostly Gnome) I thought that the reason for the problem could be GDM, so I decided to use Plasma (with SDDM), to see if the login manager is the reason.

I am know one can also change only DM, but I was changing either full distros or DEs.

So far I have tried:

  • Gnome (Fedora, PopOs) and GDM.
  • Plasma (Manjaro) and SDDM
  • Mint (Cinnamon) and LightDM/Silck


How you were able to re-login without reboot? In my case, I always had to hard-reboot (press and hold power button), as I was not able to change tty-s.

Anyway, the problem seems to be related with Dell laptops with Nvidia Carts.
I also dual boot, and in Windows it seems to work as expected.

There is some solutions or work around to resolve this “not Linux problem”?
Which group should fill a bugs?

Or I must change my Dell GS-G5 laptop?

sudo inxi -F --no-host
System:    Kernel: 5.7.10-201.fc32.x86_64 x86_64 bits: 64 Desktop: Gnome 3.36.4 Distro: Fedora release 32 (Thirty Two) 
Machine:   Type: Laptop System: Dell product: G5 5590 v: N/A serial: G267HX2 
           Mobo: Dell model: 0CNDTP v: A01 serial: /G267HX2/CNPEC0002O00OZ/ UEFI: Dell v: 1.11.1 date: 11/11/2019 
Battery:   ID-1: BAT0 charge: 53.6 Wh condition: 53.6/60.0 Wh (89%) 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP L2 cache: 12.0 MiB 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 896 2: 892 3: 879 4: 895 5: 898 6: 898 7: 897 8: 896 
           9: 879 10: 838 11: 862 12: 857 
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] driver: nvidia v: 440.100 
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
           Display: server: Fedora Project X.org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 1920x1080 
           OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100

Hi everyone,

I am also having similar issues with the Lenovo G50-80 since I upgraded OS from dual boot (Windows + Fedora 23) to single boot Fedora 32.

Following is a summary of the unexpected things I have observed so far:

  1. Almost all the time “sleep/suspend” is not working and I have to go for the forced shutdown of the system. Because when this happens non of the other key responds. No matter what I try the system won’t wake up.

  2. Power issue: A few times when the system is inactive for some time and if there is a sudden interruption in the AC power supply (like I remove AC adaptor) then within a fraction of the second system will show low battery warning and try to go to sleep. If I am quick enough to either reconnect the AC adapter or press any key then the session is saved else it will end up in a frozen state. However, this does not happen if the system is active i.e. external power cut won’t lead to system freeze if I happen to be working on it the system at that moment.
    Note on power setting: I have cross-checked the power setting. Options are: Blank screen = Never, Suspend when on battery= Never, Susped when on AC= Never.
    Note on battery condition: Battery is in good condition and still provides a backup of about 3 hours under average working load.

  3. Blinking screen: When I try to save the system from a sudden power cut as mentioned in point-2, for a few seconds screen will starting blinking. It is so annoying that a few times user will get locked and I have to log in (unlock) while the screen is still blinking. However, after login, the screen gets stable (i.e. stop blinking) in a few seconds. This happens even when I have reconnected back the AC power quickly.

  4. Boot issue: A few times system won’t boot completely and will be stuck somewhere in between. For this, I have to do a forced reboot using Ctrl+Alt+Delete and just hope that it will reboot properly and won’t freeze again. However, a few of the time, even the Ctrl+Alt+Delete also won’t help to reboot and I have to do a hard reboot by pressing the power button.

  5. Blank screen while booting: A few to times after pressing the power button only the keyboard and WebCam LED response and the screen stay off (blank). This is the most funny part, but, the screen shows some signs of life if I try to close it. (This seems to be a hardware issue, right? But why only a few times?)

Please let me know if you are able to figure out what the problem is. Are these issues related to software or hardware? Also, should I wait for a fix or go for a new laptop because I am sure that a lot of forced shut-downs (with the power button) will lead to the hard-disk crash one day.

The system info is provided below. Kindly let me know if you need any other system information.

Many thanks.


H/W path Device Class Description
system Computer
/0 bus Motherboard
/0/0 memory 12GiB System memory
/0/1 processor Intel(R) Core™ i5-5200U CPU @ 2.20GHz
/0/100 bridge Broadwell-U Host Bridge -OPI
/0/100/2 display HD Graphics 5500
/0/100/3 multimedia Broadwell-U Audio Controller
/0/100/14 bus Wildcat Point-LP USB xHCI Controller
/0/100/16 communication Wildcat Point-LP MEI Controller #1
/0/100/1b multimedia Wildcat Point-LP High Definition Audio Controller
/0/100/1c bridge Wildcat Point-LP PCI Express Root Port #1
/0/100/1c.2 bridge Wildcat Point-LP PCI Express Root Port #3
/0/100/1c.2/0 enp2s0 network RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/1c.3 bridge Wildcat Point-LP PCI Express Root Port #4
/0/100/1c.3/0 wlp3s0 network QCA6164 802.11ac Wireless Network Adapter
/0/100/1f bridge Wildcat Point-LP LPC Controller
/0/100/1f.2 scsi1 storage Wildcat Point-LP SATA Controller [AHCI Mode]
/0/100/1f.2/0.0.0 /dev/cdrom disk DVDRAM GUC0N
/0/100/1f.3 bus Wildcat Point-LP SMBus Controller
/0/2 system PnP device PNP0c02
/0/3 system PnP device PNP0b00
/0/4 generic PnP device INT3f0d
/0/5 input PnP device PNP0303
/0/6 generic PnP device SYN2b37
/0/7 system PnP device PNP0c02
/1 mmc0 bus MMC Host

Hi everyone,


Just found that if I keep pressing keyboard keys (like Enter, spacebar) for some time (like for about a minute), the system eventually responds after some time. This happens even when the system has gone to freeze state and the keyboard appears to be unresponsive (i.e., no change in the state of NumLock, CapsLock key’s led indicator after pressing them). After some time, the system wakes up but with a blinking screen which also gets resolved after few seconds of unlocking the user.

But, I am still wondering what the issue.

Note: This blinking (toggling) screen I first observed when I booted the Fedora32 from a USB stick-drive. Due to some reason, I had to physically close the laptop screen when Fedora32 when I was using it from a USB stick drive. But, after some time, when I opened the laptop screen, it was toggling. That time I thought it may be due to a low data transfer rate between USB stick-drive and laptop. But, right now I am booting Fedora32 from an internal hard disk (Lenovo 1TB). So wondering what can be the reason.
Also, I have a RAM of 12GB and SWAP of 15GB so memory is not a problem I guess.

Let me know if anyone of you has figured out the reason for this issue!

Thanks and regards,

Hey, I am curious is there anything special about installing Matlab on Fedora? Did you use a specific guide for this?

Well the issues typically occurs because Fedora has newer(cutting/bleeding edge) packages, whereas Matlab uses old packages. Officially, Fedora is not one of the supported by Matlab distros.

e.g. this time when I was installing Matlab 2019b on Fedora 32, it was only using software opengl (and apparently this was also case on “supported” distro). The installer of Matlab 2020a would not even start, as there was a conflict with lybcrypt package, and solution was to copy it from debian docker, or so (found in Matlab forums via googling).

At the moment, with 2019b you can install without issues, and if you want hardware opengl in Matlab you can create/edit the matlab.desktop file with the following exec

exec =env MESA_LOADER_DRIVER_OVERRIDE=i965 matlab -desktop

you will also see an error related to gtk2 modules, for that you can also add

env LD_LIBRARY_PATH=/usr/lib64/gtk-2.0/modules in your exec line

1 Like

leading edge != cutting/bleeding edge

Fedora keeps applications updated true but also has the stability that you would get to see in any other standard release based distro as discretion is maintained while updating packages and none are pushed to the point where their dependencies are unavailable or too unfit to be compatible.

Sure! thanks for the correction, I always confuse differences in all those edges :slight_smile:

My point was that typically packages in Fedora are much newer (or getting faster (version) updates) than in Ubuntu or Debian version (especillay the ones that are supported by Matlab, that also lag at least a Distro release behind).

I was not implying that Fedore is less stable because of newer packages.

1 Like