[fedora 32, gnome on Xorg, Kernel 5.9.8 & 5.9.9] dark screen on dual display

Hello all,

I’am encounter a problem for a dual screen display.

I’am still in f32.
I have a HP laptop, with an external minotor wchich is my main screen when I’am working at home.
I have a NVIDIA video card.
Until kernel version 5.8.18-200.fc32.x86_64, all was working fine

Last week, I installed the kernel
And this morning
For both I have the same problem:
The logon screen have a correct display on both screen.
After login to my account (“GNOME on Xorg”), the both display are now completely dark. I see only the cursor of the mouse on both screen.
If I unplug the external display (displayport cable), after a certain time (more than 1 minute), the display is correct on the laptop.
If I plug again the external monitor, immediatly the both display are coming dark again (except the cursor of the mouse).

But if I boot with the previous kernel “5.8.18-200.fc32.x86_64”, all is working fine.

This morning, after booting on 5.9.9, I launched the command:
journalctl -b 0 --no-pager | fpaste

The result is here:

Note: last week, I tried, to logon on “wayland”. The display was correct on both screen for some minutes. After that it was a terrible mess.
I presume it’s due to the nvidia driver, which have still problem with wayland as I read it on several blogs.

I’am working with fedora since version 23, and it’s the first time, I have a major problem after a kernel update.
I tried to correct it myself on searching on different blogs, but no way.

Thanks in advance to help me to solve this problem.

1 Like

Please see this topic:


1 Like

Thanks a lot FranciscoD for your answer.

In case it’s useful, I put the informations concerning my graphic card:

lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [Quadro 1000M] (rev a1)

lshw -C video
description: VGA compatible controller
product: GF108GLM [Quadro 1000M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:40 memory:d0000000-d0ffffff memory:c0000000-c7ffffff memory:c8000000-c9ffffff ioport:4000(size=128) memory:c0000-dffff

rpm -qa | grep nouveau