Fedora 30 upgrade log in loop

Hi Fedora Community
I have recently upgraded to Fedora 30. The upgrade appeared to go well.
When trying to log in I was stuck in a log in loop. After reading up I tried creating a new user and the new log in was fine. I then tried disabling gnome extensions using gsettings get org.chrome.shell enabled-extentions “” and got the following:
CRITICAL **: Failed to get connection to xfconfd: Cannot autolaunch D-Bus without X11 DISPLAY
dconf-WARNING 88: failed to commit changes to dconf Cannot autolaunch D-Bus without X11 DISPLAY
I am a novice in these matters but have been using Fedora for many years. I rely on it. Any help would be gratefully appreciated.

1 Like

Same here.
It seems to login, but instead of gnome session, login screen reappears.
Tried both, Wayland and Xorg…
Password ist definitely correct: I tested by Input of a wrong one that was instantly marked as being wrong, so no Typo or such!
Maybe usefull information: I had my system set up to automatically log in as I’m the only user and disk encryption is on…

As suggested in thread

I created a new user and the gnome session came up. So I’m going to disable my extensions one after the other, as the extensions-tool has no “all” option…

Of my 11 extensions installed, I disabled all but caffeine. Now the Gnome session is up!

1 Like

I am stuck in the login loop and can’t create a new user or don’t know how. I clicked “not listed” and made a new login and pass and it says “Sorry that didn’t work. Please try again” ? Help is greatly appreciated! I cannot load any of the old versions as they do the same login loop. I used dnf upgrade to upgrade through Terminal. I did everything right, upgraded fully before install followed the instructions to a T. I tried recovery boot, to no avail…

Update so far: Got into terminal, moved gnome-shell/extensions folder to /home and rebooted, got in. Now to get my extensions back. Be back for further update.

1 Like

Solved my Log in loop issue. It was an extension.
FransciscoD’s info was the key.
Thanks to mcbuhl for his input


Could you give me a pointer to how you enabled each extension one at a time to find the culprit?


Hi @svandive, welcome to the community. Please have a look at the posts in #start-here if you’ve not had a chance to yet.

Were you able to access the solution to this topic? It has the information you’re looking for?

Yep, I see now the best approach, thank you for having this forum!! Very helpful.



I just completed my upgrade from WS 29 to WS 30. My first logon attempt resulted in a loop. I went back to WS 29 and all worked. Then I remembered that in WS 29 (maybe 28) I had to use GNOME Classic. On that level, the logon would fail and I would get the logon screen back. I rebooted to WS 30 and set to GNOME Classic and all is working. I reached this solution by searching the log and finding an error in Wayland as part of the logon failure. After a little more research, I found how to disable Wayland and continue. Just a hint to anyone else having this logon problem. Thanks to all who have posted things that have helped me in my FEDORA journey.