Login to gnome desktop fails after update

Hi Community!

I’m lately having issues with my desktop-pc (not the newest) and i suspect it might have to do with a recent update. I’m performing updates every week or so but reboot my machine rather seldom so if this is kernel related I’m unsure since which update this may have occurred since there were several performed since my previous reboot.

After booting, the gnome-greeter appears as usual but when I try to log in, the screen stays blank (in case of xorg-gnome; waited for >10 mins) or goes back to the user-selection (in case of default gnome (wayland)).
I can switch to tty3 and log in there; # systemctl status gdm gives me:

> gdm.service - GNOME Display Manager
>    Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: enabled)
>    Active: active (running) since Thu 2019-07-04 16:36:37 CEST; 39min ago
>  Main PID: 1670 (gdm)
>     Tasks: 3 (limit: 4915)
>    Memory: 10.0M
>    CGroup: /system.slice/gdm.service
>            └─1670 /usr/sbin/gdm
> Jul 04 16:36:37 f2x systemd[1]: Starting GNOME Display Manager...
> Jul 04 16:36:37 f2x systemd[1]: Started GNOME Display Manager.
> Jul 04 16:36:38 f2x gdm-launch-environment][1696]: accountsservice: Could not get current seat: No data available
> Jul 04 16:38:01 f2x gdm-password][4002]: accountsservice: Could not get current seat: No data available
> Jul 04 16:38:07 f2x gdm-password][4002]: gkr-pam: unable to locate daemon control file

Peeking into the journal for something obvious, an entry mentioning ‘gnome-session-binary[…]: Unrecoverable failure in required component org.gnome.Shell.desktop’ but upon closer inspection I found that this error is also present in much earlier log-sections where gnome was running fine.

As far as I can remember, everything worked fine with the old-style-gdm-launch (before the recent prettified loader with the fedora-logo in colour).

Some data about my system:

  • Fedora-30, updated from at least F29, maybe 28.
  • Running on some old nvidia-card (GeForce 210)
  • nouveau-driver used (# lsmod | grep nouveau yields 8 hits such as video, drm, wmi,…)
  • no nvidia-package installed (# dnf list installed | grep nvidia yields no results)
  • gnome-shell-3.32.2-2, mutter-3.32.2-3 currently installed

Some things I’ve tried so far:

  • underlying filesystems are all clean (checked offline),
  • disabling wayland through uncommenting WaylandEnable=false in /etc/gdm/custom.conf + reboot did not bring any change,
  • booting an older kernel (5.1.8 instead of 5.1.15) did not bring any change.

As a temporary workaround I’ve installed LXQT which works ok but on this machine I’d prefer gnome and would like to get it back working.

I’m currently considering to # dnf history rollback <id> or # dnf history undo <id> to get closer to the possible cause of my issues.

Update: a rollback to a specific ID failed with a python-exception in /usr/lib/python3.7/site-packages/dnf/db/history.py, see below post for details.

Update: undoing certain history-IDs also seems not possible as the underlying packages seem to have been rotated out of the repo-metadata and the respositories. :confused: At least i get Error: no package matched after a series of No package <name> available. :thinking:

Any further ideas where else to look into?

Many thanks,

well, so I tried to rollback some of the last updates to get back to a point where i remembered that my system used to boot fine though # dnf history rollback 167 but dnf exits unclean in this case producing the following output:

Last metadata expiration check: 1:34:30 ago on Fri 05 Jul 2019 07:06:09 AM CEST.
Rollback to transaction 167, from Mon 24 Jun 2019 07:46:19 AM CEST
  Undoing the following transactions: 168, 169, 170, 171, 172, 173, 174, 175, 176, 177, 178
    Upgraded  GraphicsMagick-1.3.31-5.fc30.x86_64                           @@System
    Upgrade   GraphicsMagick-1.3.32-1.fc30.x86_64                           @updates
    Upgraded  ModemManager-1.10.0-1.fc30.x86_64                             @@System
    Upgrade   ModemManager-1.10.2-1.fc30.x86_64                             @updates
    Upgraded  ModemManager-glib-1.10.0-1.fc30.x86_64                        @@System
    Upgrade   ModemManager-glib-1.10.2-1.fc30.x86_64                        @updates
    Install   NetworkManager-ppp-1:1.16.2-1.fc30.x86_64                     @updates
    Install   NetworkManager-tui-1:1.16.2-1.fc30.x86_64                     @updates
    Install   PackageKit-Qt5-1.0.1-3.fc30.x86_64                            @fedora
    Upgraded  abrt-2.12.0-2.fc30.x86_64                                     @@System
    Upgrade   abrt-2.12.1-1.fc30.x86_64                                     @updates
    Upgraded  abrt-retrace-client-2.12.0-2.fc30.x86_64                      @@System
    Upgrade   abrt-retrace-client-2.12.1-1.fc30.x86_64                      @updates
    Upgraded  abrt-tui-2.12.0-2.fc30.x86_64                                 @@System
    Upgrade   abrt-tui-2.12.1-1.fc30.x86_64                                 @updates
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 192, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 115, in cli_run
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 1129, in run
    return self.command.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/commands/__init__.py", line 998, in run
    ret = self._hcmd_rollback(self.transaction_ids)
  File "/usr/lib/python3.7/site-packages/dnf/cli/commands/__init__.py", line 912, in _hcmd_rollback
    return self.base.history_rollback_transaction(extcmds[0])
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 636, in history_rollback_transaction
    self.output.historyInfoCmdPkgsAltered(mobj)  # :todo
  File "/usr/lib/python3.7/site-packages/dnf/cli/output.py", line 2014, in historyInfoCmdPkgsAltered
    last.name == pkg.name and pkg.action == libdnf.transaction.TransactionItemAction_UPGRADE):
  File "/usr/lib/python3.7/site-packages/dnf/db/history.py", line 56, in name
    return self._item.getRPMItem().getName()
AttributeError: 'NoneType' object has no attribute 'getName' 

so well, this is likely not connected the my original issue but limits what i can do to further investigate what may be the cause…