Fedora 30 Black screen on boot, install no problem

This question has been asked before, but the solutions I found on here and through further googling didn’t help me out.
I have an old pc (Asus all in one with an integrated Intel 2500 graphics card). It was running Fedora 27 flawlessly, but I decided a fresh install of Fedora 30 today.
Starting the LiveUSB was painless, and installing it from there worked like a charm. After installing I took out the USB and rebooted the machine. The following is what happened:
It went normally through the first boot sequences. Eventually I saw this white circle turning around to show me things were being loaded. After a few seconds the screen went black.
I could still hear the harddrive spinning, so I assumed things were being initialized for the first boot. But it stayed like this forever (+30 minutes).

I retried a few times. Reinstalled. Tried to add or remove certain things from the bootloader, as suggested on some webpages. (Most of these suggestions refer to NVDIA drivers, but this machine has an Intel chipset. Tried the suggestions anyway).

I am clueless…
Will try to install Fedora 29 instead. See what happens. But I’d prefer 30 of course

Troubleshooting the boot failures and the workarounds:

1 Like

Thanks for the ideas.
Actually, I now settled for F29, as I have some deadlines before the end of the month.

I tried some graphic modes, still, but to no avail.
I’ll try and see what the Boot failures can tell me, and get back here when I did.

1 Like