Fedora 30 black screen on boot

So… Let’s boil it all down. First of all, it is not only Fedora 30. I tried to get a live USB of Manjaro (with GNOME) and I also had a black screen on boot. However, I actually can boot a live USB of Fedora 30 if I go to troubleshoot and start with minimal graphics. If not, it does the preparation and after the 4th-5th “[OK]” the screen goes blank. My monitor receives some kind of signal as it did not turn off (It automatically turns off and on when there is signal) and my computer was still running.

At first I thought waiting would do the trick but after 2h… You know what happens. I could not find a single solution to my issue as the secure boot is disabled and even with CSM disabled, I still get a black screen. Maybe it could be my USB? I will try with a new one later on, but I doubt that could be it.

Computer Specifications:

Motherboard: ASUS A320M-K\BR
GPU/VGA Adapter: Sapphire Pulse AMD RX 580
CPU: AMD Ryzen 2700

Obs.: If more hardware specifications are needed, I can follow up with it.

Hi wizardlink,

I will see what we can figure out together.

Can you run the below in the terminal so we can confirm the driver being used:

lspci -k | grep -EA3 'VGA|3D|Display'

and see if anything useful is shown in the logs.

journalctl -b (shows log from current boot)


Sorry for the delay, it was 4AM for me when you replied my message.

A quick observation, I ran these commands in the troubleshoot mode, just in case you forgot.

Concerning the journalctl… There was nothing really interesting about VGA so I wonder what it could be. The only weird thing I could spot, was “No NUMA configuration found”, if you need I can also post that.

Sorry if I am disturbing… But the new layout got me confused for a moment, it looks like I replied to my own thread instead of you. I hope I did not disturb, this issue is just generating too much stress lately.

Run livedvd and

  1. edit start fedora 30 ( press e ),
  2. add nomodeset after ‘quiet’
  3. start boot with ctrl + x
    see if you boot up properly

Sorry for the delay, I were out in a trip. I did try that yesterday and it does boot. However it behaves and lags as much as in secure mode. It looks like (spoke in an ASUS forum) that my motherboard has outdated firmware which makes it incompatible.