Fedora 29 - System restarts instead of resuming from hibernate (enc swap)

I have a system that uses encrypted swap (details below). When I make it hibernate, I can see in the journalctl logs that it goes to hibernate, but it starts afresh instead of resuming from hibernate when powered on. Did I miss out configuring anything?

lsblk -f

NAME                                          FSTYPE      LABEL UUID                                 MOUNTPOINT
├─sda1                                        vfat              6FFE-3506                            /boot/efi
├─sda2                                        ext4        boot  8c7c56d7-efa0-4cea-9340-d5b52241d008 /boot
├─sda3                                        ext4        root  3b4d9964-0db4-4473-8f72-9b60736ac7da /
└─sda4                                        crypto_LUKS       cc5065a6-8ea4-460b-a889-abe565b0bf49 
  └─luks-cc5065a6-8ea4-460b-a889-abe565b0bf49 swap              0bc13859-8150-4f94-81a0-c57bdf53bbc5 [SWAP]
└─sdb1                                        ext4        data  b37198e9-3298-4fc8-9632-4dfbeb9e7494 /mnt/CT250MX500SSD1


/dev/mapper/luks-cc5065a6-8ea4-460b-a889-abe565b0bf49 swap swap defaults,x-systemd.device-timeout=0 0 0


luks-cc5065a6-8ea4-460b-a889-abe565b0bf49 UUID=cc5065a6-8ea4-460b-a889-abe565b0bf49 none luks,noauto,discard

This is how I enabled hibernate


GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-cc5065a6-8ea4-460b-a889-abe565b0bf49 **resume=/dev/mapper/luks-cc5065a6-8ea4-460b-a889-abe565b0bf49** rhgb quiet"

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
Generating grub configuration file …
Found linux image: /boot/vmlinuz-5.2.18-100.fc29.x86_64
Found initrd image: /boot/initramfs-5.2.18-100.fc29.x86_64.img
Found linux image: /boot/vmlinuz-5.2.17-100.fc29.x86_64
Found initrd image: /boot/initramfs-5.2.17-100.fc29.x86_64.img
Found linux image: /boot/vmlinuz-5.2.7-100.fc29.x86_64
Found initrd image: /boot/initramfs-5.2.7-100.fc29.x86_64.img
Found linux image: /boot/vmlinuz-0-rescue-a255898362364eff8b7a0f9e5b90b993
Found initrd image: /boot/initramfs-0-rescue-a255898362364eff8b7a0f9e5b90b993.img
Adding boot menu entry for EFI firmware configuration

I noticed resume parameter is not showing here

sudo dracut --print-cmdline
root=UUID=3b4d9964-0db4-4473-8f72-9b60736ac7da rootfstype=ext4 rootflags=rw,noatime,nodiratime,commit=60,stripe=8191

but it does, here

cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-5.2.18-100.fc29.x86_64 root=UUID=3b4d9964-0db4-4473-8f72-9b60736ac7da ro rd.luks.uuid=luks-cc5065a6-8ea4-460b-a889-abe565b0bf49 resume=/dev/mapper/luks-cc5065a6-8ea4-460b-a889-abe565b0bf49 rhgb quiet

journalctl -u systemd-hibernate

System reboots after suspending.

-- Reboot --
Oct 10 22:56:55 hystou5250.lan systemd[1]: Starting Hibernate...
Oct 10 22:56:55 hystou5250.lan systemd-sleep[3424]: /usr/lib/systemd/system-sleep/displaylink.sh: line 7: /tmp/PmMessagesPort_out: No such file or directory
Oct 10 22:56:55 hystou5250.lan systemd-sleep[3424]: Suspending system...
-- Reboot --

Happy to provide more diagnostic info. Please let me know if you want me to run any commands and paste the output here.

Did you ever find a solution to this? I’m having the same issue with a fresh install of fedora 32 on an x1 carbon, and can’t find a solution so far.

After some more time investigating, I decided to check dracut. Turns out that, for some reason (possibly related to that --print-cmdline issue you have?) it’s not loading the resume module by default for me. Manually adding the resume module made it work :slight_smile:

Sorry for the late response. Missed it somehow.

I found that Fedora 30 (if memory serves me right) onwards this was fixed and the installer would add the resume parameter to grub cmdline. Good thing you managed to resolve it by adding the resume parameter manually.