Failed USB stick - write access unavailable


I back up to a USB stick almost daily. Today whilst the stick was plugged in to a USB hub I added another different USB device to the hub and the stick suddenly switched to read-only, unfortunately during a backup. Now when I plug in the stick I see this:

Jul 13 12:11:12 kernel: EXT4-fs (sda1): INFO: recovery required on readonly filesystem
Jul 13 12:11:12 kernel: EXT4-fs (sda1): write access unavailable, cannot proceed (try mounting with noload)

I have been able to mount read-only using the noload arg as suggested and have saved the data. I’d like to reuse the stick if possible - however it remains stubbornly read-only. I can run fsck but of course it cannot fix anything as it’s not possible to write. If I try to force rw mount:

$ sudo mount -o rw,noload /dev/sda1 /mnt/mount
mount: /mnt/mount: WARNING: source write-protected, mounted read-only.

Trying to set the read-only flag on the device does not seem to work:

$ sudo hdparm -r0 /dev/sda1

 setting readonly to 0 (off)
 readonly      =  1 (on)

Also tried with blockdev:

sudo blockdev --setrw /dev/sda1

But still the device reports as read-only. No change after a reboot either. How can I work out what exactly is forcing the read-only mode? It seems as if it must be the device as nothing I do makes any difference, but it would be good to confirm. It looks like the stick is probably dead.


That is the way USB sticks fail. They go to read-only and cannot be recovered other that read the data from them.

The fix: backup to a different device and dispose of that one.


Before that, you can always try using Gparted to reformat it. If it works, fine; if not, you haven’t lost anything except a little time.

1 Like

Thanks all - I could not get any further with Gparted - no way around the FS being read-only it seems as all operations I tried failed. This stick is for the bin it seems!