Failed to upgrade to Fedora 38


I tried to upgrade from Fedora 37 to 38 using dnf upgrade. Downloading and installation appears fine, or normal. Did not see any error. However, when rebooted, when entering gdm I was given a white screen with message of “Oh no, something went wrong…”. I did some search, and most relevant posts suggest that is related to mesa-*-freeworld packages. But I don’t have them installed yet. Under text mode to dnf install other suggested packages, I got error messages that could not resolve hostname. Sounds like wifi has not been activated. Any advices are appreciated.

Please provide hardware details: Iif possible, inxi -Fzx outout pasted as text bracketed by three backquotes, otherwise whatever details you can provide (e.g., link to model details on a vendor site or Linux Hardware) and your current system status:

  • Can you boot the system to Fedora?
  • Is the system dual boot, and can you boot the other OS?
  • If Fedora boots can you you get a GUI or are you limited to the console?
  • Does the system have internet access (wired, USB tethering, etc)?

Common causes of failed upgrades are skipping the pre-upgrade updates to the existing Fedora installation, 3rd party packages that don’t have Fedora 38 versions, and running out of disk space. Upgrades are disk and memory intensive and may reveal hardware failures that weren’t noticed in normal operation.

Wifi failures after linux install/upgrade are not rare. A cheap USB wifi dongle that is supported by a driver bundled with the linux kernel is (too?) often useful. If you have a cell data plan you may be able to tether a cell phone for network access over USB.

Yes, I can boot to Fedora 38. Even when I tried to boot to the Fedora 37, I still ended up in Fedora 38.

The system is not dual boot. Fedora Linux only.

I can’t get GUI. Before seeing Oh no message, it was starting gdm. I suspect it has something to do with graphics.
Graphic display related hardware based on the output of inxi -Fzx:
Devide-1: Intel UHD Graphics 620, Vendor: Hewlett-Packard, driver: i915; v: kernel, arch: Gen-9.5; bus-ID: 00:02:.0
Device-2: Nvidia GP100M (GeForce MX150), vendor: Hewlett-Packard; driver: nvidia; v: 530.41.03; Arch: Maxwell; bus-ID: 01.00.0

When I even directly connect the computer to cable network line, sudo dnf update does not work: curl error (6), couldn’t resolve hostname…

Please post the full output of inxi -Fzx as requested above. You may use the triple backquotes on the line above and below the posted text to retain the formatting, or highlight the posted text and use the </> button on the toolbar to do the same.

It is important that one provide the requested info so we may see the necessary details and thus provide accurate suggestions for the fix.

Thanks Jeff, and George,

Because the other computer being upgraded is not able to connect to network, I post with a figure.

Hope you can read.

For the network issue, it seems that the wifi adapter is properly defined but not connected.
The fact the wired network seems up makes the wifi connection lesser importance until the other issues are resolved.

To figure out why there is no internet connection we need to know if it is network or dns.
Please try ping and let us know the response. If it fails then it may be network related. If that works then the issue may be dns related.

1 Like

With wifi, ping: connect: Network is un reachable
With cable, ping: connect: Network is unreachable

But when connected with cable, I see a line: [316.421040] r8169 0000:02:00.1 enp2s0f1: Link is Up - 1Gbps/Full - flow control off
Ipv6: ADDRCONF(NETDEV_CHANGE):enp2s0f1: link becomes ready.

What is the output of ip route?
Once you have that and can see the address of the gateway router please try a ping to that address and provide the results.

While troubleshooting this one easy step is to go into the control panel for the network and disable the IPv6 config to eliminate the potential interference should the router not properly support IPv6 but the PC be trying to use IPv6.

1 Like

WiFi doesn’t work for me if I login from a non graphical session unless I have a graphical session running at the same time, maybe because the DE provides the “secrets” to the Network Manager. (Maybe you have the same issue). You may try to connect using nmcli:
nmcli device wifi connect 'WiFi SSID' password 'YOUR_WIFI_PASSWORD'

However, I expected the ethernet connection to work since it doesn’t require secrets.

Please post the output of ip addr

I assume you mean from GRUB? That will make you boot using a Fedora 37 kernel but your system is Fedora 38.

Can you describe this setup a bit more? It sounds like you have a separate cable modem, connected by ethernet to the wifi router / gateway. And then you’re connecting the computer to the modem directly instead. Is that correct?

It may be that your internet provider expects[1] the wifi router, and plugging in another device won’t work.[2]

  1. by ethernet MAC ↩︎

  2. without cloning the MAC or calling the ISP to change it ↩︎

Hello all,

Thanks for all your responses and help. During the past 24 hr, I did not see hope of fixing, because it was not able to reach Internet. I just did a fresh install.

Overall, Fedora upgrade has been quite smooth up until Fedora 37. There might be some errors that have been accumulated during previous successive upgradings. Fresh installation of Fedora 38 is quite smooth.