Fedora 38 upgrade fails with no reason given

I’m trying to upgrade to Fedora 38 from a fully up to date Fedora 37 Workstation install. However, when I try to download the update it gets to 10% and stops, going back to as if I hadn’t done anything at all.

Video of the issue:

Is this upgrade unsupported at this time, or is the upgrade just broken?

Worked around this by doing:

sudo dnf install dnf-plugin-system-upgrade
sudo dnf system-upgrade download --releasever=38

Got 0 errors doing it that way, no idea why the GUI upgrade path just doesn’t work.

It would be great if you could run journalctl -f and see what log messages get printed during the unsuccessful download, that would help us to debug the issue. But it’s too late now, as I understand.

I had the same issue, and journalctl -f showed this:
PackageKit[1491]: upgrade-system transaction /6132_ceaaecde from uid 1000 finished with need-untrusted after 707ms
Upgrading with dnf system-upgrade worked, but asked to import two GPG keys from a third-party repository, which might be related?

That might be related. Are you able to provide more details? Which repo keys did you need to import with dnf?

We have seen a few reports of failure with the software upgrade but success with a dnf upgrade.
Is failure to import the keys a likely cause? Maybe?

When I upgraded via the command line I needed to add 2 keys as well, one for the Tailscale repo and one for the ProtonVPN repo.

[ngupton@andromeda ~]$ cat /etc/yum.repos.d/tailscale.repo 
name=Tailscale stable

[ngupton@andromeda ~]$ cat /etc/yum.repos.d/protonvpn-stable.repo 
# ProtonVPN stable release
name = ProtonVPN Fedora Stable repository
baseurl = https://repo.protonvpn.com/fedora-$releasever-stable
enabled = 1
gpgcheck = 1
gpgkey = https://repo.protonvpn.com/fedora-$releasever-stable/public_key.asc