F39 iso won't run in QEMU on OpenBSD

I got an F39 installer iso today and plugged it into a QEMU without kvm on an OpenBSD and selected start F39 in Grub menu (must add “noapic” to the kernel boot parameters). Everything proceeds fine, systemd messages roll, then gdm starts, I get a mouse that moves, but then everything stays like that for a while, and then I get a gray screen saying there was a problem with a “Log Out” button. DE never starts.

Should I go for Fedora Server install to see if it even boots?

Well, installing Fedora Server is one potential solution, I’ll mark this solved for now. It has no desktop environment, so should really isolate if that is an issue.

Suggest you compare QEMU versions between a f39 system and OpenBSD to see if the OpenBSD is too old maybe?

Also check on the graphics options that you setup for the OpenBSB F39 VM maybe the default is needs changing.