F38 "Failed to start nvidia-powervice - nvidia-powerd service" at boot


For some time I see the message [FAILED] Failed to start nvidia-powervice - nvidia-powerd service when the PC is booting up.

This message appears for a split second on boot and I have only recently noticed that it appears.

Even when I noticed the message I never really cared about it because I never encountered any issues or problems.

example: godot
It is only when I started to play around with the godot game engine that I encountered issues: the software gives black screens/windows when you are in another window, moving around or doing anything really:

(sidenote: I got godot from flatpak, but if I download directly from the website I get the same issue, the issue is that godot is quite sensitive about graphical drivers and I assume that the “failed at boot error” could be the cause…)

anyway, after doing some research it appears that this error usually happens when the wrong driver is installed for a given GPU (I think?). So I checked what graphics card I have and what driver(s) I have installed.

I have a NVIDIA GeForce GTX 1050 with 535.113.01 drivers :

Consulting our favorite brand of trust, open source-ness and innocent bliss I found out that I have the correct drivers installed for my little 1050: (website)
So… after looking around on the interwebs and other forums I saw various answers and solutions to related problems; everything from re-installing drivers yourself (hell no) to awaiting a bug fix. But i don’t know if any of these solutions will work and I am a PC/software know-nothing.

So please if anyone had similar issues before, could you help me fixing this?

Kind regards,

That message is an alert and not an error.
The noted nvidia-powerd.service is for use only with specific nvidia gpus in certain laptops and really means nothing for the majority of us.

Best advice – just ignore it as a normally seen message during boot.

If you really wish to remove the message it can be removed by disabling that service.
sudo systemctl disable nvidia-powerd.service and the alert message will no longer appear.


just rebooted, the message is gone at boot.

I still have issues with godot but that is unrelated to this forum so i won’t bother you guys with it. :slight_smile: