F38 beta aarch64/os/images/pxeboot/vmlinuz file format change breaks pxe booting

Prior to F38 beta, aarch64/os/images/pxeboot/vmlinuz was a gzip file.
Now it is: PE32+ executable (EFI application) (stripped to external PDB), for MS Windows
My PXE booting aarch64 systems don’t seem to like the change.

Turns out this was due to: Linux Kernel Driver DataBase: CONFIG_EFI_ZBOOT: Enable the generic EFI decompressor
Just needed to update grubaa64.efi image.