F36 KDE wifi went out, can't detect adapter


I have an HP Stream 14-cb164wm that came with Windows 10, and I uninstalled it and replaced it with Fedora 36 KDE. It was fine for a while, but now it doesn’t show any networks to connect to, or even the option to turn the wifi on or off. Turning the computer off and back on doesn’t help, there’s no hardware wifi switch, and the BIOS doesn’t have the option to view or test devices, only disk space and memory. I have a USB wifi adapter, but for some reason it drops about 70% of the packets when I use it with Fedora.

I never got inxi so I couldn’t see if the wifi adapter was still visible, so I booted Linux Mint from a USB drive to check. The USB adapter works fine with 0 dropped packets in Mint, but the built-in adapter still doesn’t. When I run inxi -i in the terminal in Mint, the only device it finds is Realtek RTL8188EUS 802.11n Wireless Network Adapter, which is my USB one. And when I unplug it and run inxi -i again, it gives a bunch of “Use of uninitialized value” and “Could not resolve host” errors and can’t find any device data.

Is my adapter just broken? Is there something else I can try?

Thanks for any advice you have