Evolution: Failed to retrieve credentials from the keyring

This is becoming frustrating.

I use evolution to manage two calendars and 3 email accounts.

But I’m frequently presented with an error saying that mail can’t be retrieved from two Google accounts because it can’t retrieve the credentials from my keyring.

The other account I can just go into the server settings in Evolution, have a fiddle about and get it to run. Google however is handle from the Gnome Settings, the “Connect To The Cloud” bit.

This is where it gets dicey, I check my Goggle a/c (s) and am informed by settings manager that Goggle has told it that the credentials have expired and I have to re-connect - so I re-enter the usernames and passwords, allow Gnome as an authorised application to access my mail/calendar/contacts etc etc. Click the “Allow” button to complete then …
Have to start again as the window says my credentials have expired and … well you can see the loop here.

The last time I tried running ’ dnf update’ then rebooted - this worked for a while.
Now - nope.

There are no updates and rebooting just cost me the time it takes to reboot

What’s going on with this Gnome Vs Google conflict

I recall having this issue before, I deleted all the folders in ~/.local/share, ~/.config, and ~/.cache related to GOA and Evolution (they were named goa-something and evolution IIRC), then rebooted and signed back in and it worked.

please try this it has sortedm my gmail issues https://bugzilla.redhat.com/show_bug.cgi?id=1340203

apologies it is the command here https://www.reddit.com/r/gnome/comments/6cvx5p/weird_evolution_authentication_keyring_problem/

/usr/lib/gnome-online-accounts/goa-daemon --replace

type the above in your terminal