Every chromium based web browser does not display this page properly, Firefox works


The page in question: [Redacted]

I’ve uploaded 2 screenshots. One where the web page does not display properly in any Chromium based web browser (Google Chrome, Chromium, MS Edge) and the other screenshot where the page displays properly in Firefox.

There are no extensions in any of my chromium web browsers, there are no console errors displayed at all when hitting F12 and refreshing the page, I’ve removed every folder with the word Cache or cache in ~/.config/google-chrome, Chromium and Edge were fresh installs and they also have no errors in the console logs when hitting F12.

There are no errors or any relevant outputs from journalctl -xe, my system is AMD based and I used sudo dnf install xorg-x11-drv-amdgpu, which ran successfully but didn’t resolve (I use X11, I’ve disabled Wayland) but, even when I enable and used Wayland, the issue persists.

When I installed Fedora 40 Workstation, I ran the following:

sudo dnf swap mesa-va-drivers mesa-va-drivers-freeworld
sudo dnf swap mesa-vdpau-drivers mesa-vdpau-drivers-freeworld

so, in desperation, I reversed this operation and swapped freeworld back to defaults and restarted, but the issue persists.

Also, I’m not missing any updates, dnf upgrade ran successfully. I’m not sure what else I should be doing to resolve, anyone have any other ideas? Thanks in advance.

System info:

Fedora Linux 40 (Workstation Edition)
ASRock B550M Pro4
AMD Ryzen™ 5 5600 × 12
AMD Radeon™ RX 6650 XT
32.0 GiB RAM
16.5 TB DISK
Linux 6.8.11-300.fc40.x86_64 KERNEL
Wayland/X11 WINDOWING SYSTEM

EDIT: I’ve also tried disabling hardware acceleration in Chrome, Chroium and Edge, didn’t resolve.

EDIT2: Removed the link from the main post. Issue resolved today for some reason after dnf update, no other changes made other than what’s mentioned below. Thank you all for taking the time to chime in and review my troubleshooting efforts.

1 Like

I’ve noticed the same thing lately on certain web pages in Chrome based browsers, especially when opening and immediately going to: chrome://extensions - it just seems to hang and then if I got to other pages and then return to chrome://extensions it works. This has been going about a month or so. Since I’m not a big chrome user and mainly stick with Fx I’ve been too lazy to open a bug about it… but yes, it is a thing. I can confirm the behavior.

Weird, I didn’t have any issues.

AMD Ryzen 5 5600G with Radeon Graphics
Radeon RX 6600/6600 XT
Chrome 126.0.6478.61-1 ```

Running Gnome wayland.

Fedora 40 as well? with the latest dnf upgrades? this makes me want to try fresh re-installing, everything I have is already backed up to 3 different hosts

Latest updates, running with updates-testing enabled.

I really wish F12 console would show me anything, or any output from journalctl. If we don’t make progress in this thread I’m totally fine reinstalling, just wanted to know if there’s other troubleshooting steps I haven’t yet considered before a fresh reinstall.

FYI It is very rare that a reinstall will change anything.

You could create a new user and log8n as that user.
Then see if the problem is still present.
If the page works it would suggest that there is a config in your $HOME that is breaking chrome.

2 Likes

… this is EXACTLY what I did after reading your post, and thank you for the idea

sudo su -
useradd user2
passwd user2
usermod -aG wheel user2

I logged out of my current user, logged into user2, launched Chrome, the homedepot page displayed normally.

I logged out of user2, logged back to my original user, launched Chrome, the homedepot page displayed normally.

I have no idea how creating a new user and switching back and forth resolved this. But this is literally what I’ve done to resolve thanks to Barry’s idea.

Maybe they fixed an issue in the server’s code and it is nothing you did.

1 Like

Issue was resolved temporarily on the main user. I just logged out and logged back in and the page doesn’t display properly again. user2 is working fine and can’t replicate the issue.

So it has to be something in my main user $HOME. If I find something I’ll update this post.

1 Like

I don’t believe this has to do with a specific webpage. Try opening chrome and then immediately go to chrome://extensions. The page just hangs. I can reproduce this on demand with edge, vivaldi and chrome.

I also do not believe this behavior has anything to do with fedora. This seems a browser and web page display problem and would not be related to the OS in any way.

It could easily be the data in the web page that is causing this, as similar issues have existed at various times ever since the internet began.

Chrome based browsers are different than mozilla browsers, and different than the many other different browsers that are available so the web page often fails to take the browser differences into account in the code that is developed.

I don’t believe this is specific to Fedora either, although it could be related to wayland or x11. I published my experience because something obviously has changed in the chrome based browsers causing this behavior.

Create a new chrome profile for your main user. Import bookmarks from other profile

I deleted ~/.cache since I have nothing to lose and diff’ed the output of ‘ps -e -o command’ between user1 (not-working) and user2 (working) and didn’t resolve. At this point I’ve lost interest and I’m switching to Firefox, especially considering that only the homedepot domain is the one where this issue is occurring so, my assumption is this is a host issue and, I’ve been meaning to switch to Firefox for a long time anyway.

Thank you all for contributing, I just wanted to troubleshoot since I have enough time (on vacation this week) and I was genuinely interested. I hope you all have a great week!

I performed dnf update today and the web page displayed normally in every Chromium based web browser for user1. Just sharing an update and please feel free to archive this post.

Unsure why user1 couldn’t display that page before, but user2 on the same workstation had no issues whatsoever. Anyway, hope you all have a great week, and thank you all for chiming in and reviewed my troubleshooting.

Possibly mark your last post as the solution?