Chromium & Chrome not starting on Fedora 37

Hi there,

I am encountering a problem on my Framework laptop with Fedora 37 installed.
The problem is that I cannot start Chromium or Chrome.

When I try to run it from terminal I get the following message:

[pd@pd-fedora ~]$ chromium-browser 
ATTENTION: default value of option allow_rgb10_configs overridden by environment.
ATTENTION: default value of option allow_rgb10_configs overridden by environment.

And from there on nothing else happens.

I searched the internet for this issue but could not find a solution.
I am happy to provide more information on my system or device if needed :slight_smile:

Thanks in advance!

EDIT: If I try to run google-chrome from terminal, nothing happens at all, it just keeps executing. The “Attention” message only shows up for chromium.

Welcome to ask.fedora @paudo

I could imagine, while you might use gnome?! the link is wrong to start chromium.

For example for Firefox I get two links, the normal one for x.11 and the second one with a -wayland prefix to start in wayland.

When I use the wrong one,Firefox also not opens.

Can you pleas check if you have more than one chromium-browser links ?

Thanks for your response!

I don’t exactly know what you mean by link. Can you explain further?

First, do you use gnome desktop? If yes, if you search in activities you should get more than one icon for the chromium-browser/chrome ?

Is there one with the prefix -wayland?

If not can you enter in your DE without Wayland and check if browsers work under x.11?

Yes I use gnome Desktop.
There is only one entry called “Chromium Web Browser”.

But I created 3 .desktop files that are supposed to start Chromium with different profiles.

But when I run chromium-browser from the command line, it also uses many arguments by default.
Might the problem be somewhere in these options?

A hint was given about wayland vs xorg. If using wayland have you tried xorg to see if it may be the DE that is at issue? or vice versa?

Sometimes the DE can be the issue and it is very easy to log in with the other DE to test things. The gear at the lower right of the login screen where you enter your password.

1 Like

Thanks a lot for that idea. I logged in with “GNOME classic” instead of “GNOME” and then I was able to start Chromium. After changing back to “GNOME” I can still start the program.

So overall a bit weird but now it works, so thanks a lot for your help :slight_smile: