Error when trying to download updates

When clicking on the “Download” button (as I often do) in Fedora’s Software app which shows available updates to the system, LibreOffice and others, I get the following error in a popup window:

Cannot download Packages/w/webkit2gtk4.1-2.42.0-1.fc38.x86_64.rpm: All mirrors were tried; Last error: Status code: 404 for

A similar error occurred a long time ago, but resolved itself after a couple days.

I’m currently running Fedora 38, GNOME 44.4, kernel 6.4.14-200.fc38.x86_64.
Any help is appreciated! Thanks.

sudo dnf upgrade --refresh

Looks like a type somewhere:

Here I have

% dnf5 info webkit2gtk4.1.x86_64
Updating and loading repositories:
Repositories loaded.
Installed packages
Name            : webkit2gtk4.1
Epoch           : 0
Version         : 2.42.1
Release         : 1.fc38
Architecture    : x86_64
Installed size  : 74.9 MiB
Source          : webkitgtk-2.42.1-1.fc38.src.rpm
From repository : <unknown>
Summary         : WebKitGTK for GTK 3 and libsoup 3
URL             :
License         : LGPLv2
Description     : WebKitGTK is the port of the WebKit web rendering engine to the
                : GTK platform. This package contains WebKitGTK for GTK 3 and libsoup 3.
Vendor          : Fedora Project

Thank you! That worked. Terminal for the win.