Error typing nvidia-settings command

Error typing nvidia-settings command

I use 4 OS in grub (boot) on my machine which is a Dell G3 3590 notebook. I have DE EndeavorOS, OpenSuse Tumbleweed and Fedra 38 Gnome 44.1 and Windows 11.

Fedora 38 does not run Nidia drivers, while all other distributions run nvidia drivers.

When typing the command below it displays the error, it is not opening the Nvidia program and only displays this message below, can someone help me please?

ERROR after typing:

$ nvidia-settings

ERROR: NVIDIA driver is not loaded

(nvidia-settings:28713): GLib-GObject-CRITICAL **: 02:28:12.450: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:28713): CRITICAL **: 02:28:12.452: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

Can someone help me? Please?

1 Like

Hi there,

Can you please note how you installed the Nvidia drivers please? What do you mean by “trial boot” too? Do you mean the live environment?

I don’t have much command of the English language, I beg your pardon when I referred to “trial boot”, it was in relation to grub with the operating systems at startup, all the Nvidia drivers work, except Fedora 38, DE Gnome 44.1. it shows that error. One note, when I manually select the Fedora OS by pressing F12 at boot, without entering grub, Fedora 38, DE Gnome 44.1 works normally with Nvidia drivers. I ask for help from you or someone in the community to solve this problem. What do I need to resolve so that by booting my notebook, accessing it through grub of the operating system Fedora 38, Gnome 44.1 I can normally access the Nvidia drivers, because in the other operating systems I turn on my notebook and access any one on grub, I can access Nvidia drivers normally. With the exception of Fedora 38, DE Gnome 44.1.

1 Like

when typing in the bash terminal:


Displays the output:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I ask the whole community for help and especially if there is any Fedora project developer who knows how to solve this problem.

In openSUSE Tumbleweed KDE, to switch video cards between intel and nvidia use the command:


prime-select boot nvidia


prime-select boot intel

Does anyone know if Fedora has a command like the one I posted above to switch video cards with simple commands?

1 Like

Hrm, I’m not sure. I know one needs to use the RPM Fusion repositories to install Nvidia drivers, and that seems to work:

There’s also this for optimus cards:

Please feel free to write in Portuguese. Community members that do speak it will be able to help you, and we others can always use translation services.

I thank you, the Fedora community here in Brazil is fantastic, but I resorted to the Fedora project website, as I have already contacted people from the Fedora community here on social networks in my country and no one has managed to provide a solution so far. Note, I already did the clean install, from scratch, when Fedora 38 was released I used this same page on the website that you sent me to install the nvidia drivers months ago, which I don’t understand and need help from Fedora community is that:

the nvidia drivers are installed, but accessing them through grub (the default I left was openSUSE Tumbleweed) because this openSUSE grub works with all the operating systems that I have installed on the notebook, when selecting the system Fedora and enter the system later, Fedora 38 Gnome does not work the nvidia driver, however if I do manual access to Fedora 38 Gnome by pressing the F12 button and selecting Fedora 38 Gnome operating system, I enter the Fedora 38 grub section and I normally access the system and the Nvidia driver works there. I want to unravel this mystery and I need the help of everyone who has the knowledge and can help me please.

1 Like

When I shut down my notebook it always display this failure message:

 [FAILED] Failed to start nvidia-powerd.service - nvidia-powerd service

I think the issue here is that when we install the Nvidia drivers from RPM Fusion, they make tweaks to the kernel boot command list in grub to ensure that it’s loaded correctly and I think it also “blacklists” the nouveau module to prevent it from loading. So, I guess if you use another boot loader instead (the opensuse one, for example), perhaps that does not have these required boot options?

These are the kernelopts in my /boot/grub2/grub.cfg file:

set kernelopts="root=UUID=b90718c5-99d6-4965-aa20-67b6f6224b06 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init "

I think the stuff from rd.driver.blacklist onwards is what is required. It’s what Silverblue/Kinonite users need to add manually, documented here (and the next section on switching between nouveau and nvidia):

You can check the file on your system to confirm. These will need to be added to the Opensuse bootloader that you use to boot Fedora.

I don’t think this one matters. I read somewhere that one can disable this service if it doesn’t work on the provided hardware (probably somewhere on this forum, I just can’t find the reference now)