Error creating libpod runtime ... database configuration mismatch

podman

#1

I tend to get an issue when running podman as a user. All commands using podman return this error message:

error creating libpod runtime: database run root /run/user/1000 does not match our run root /run/user/1000/run: database configuration mismatch

I can make podman work again by cleaning up ~/.local/share/containers/storage but this means loosing all containers I worked with.


#2

Looks like this is a known bug that was recently fixed. As far as not wiping your existing containers, I’m not sure. If you can get back to a version of podman that worked then you could possibly export them to files and then re-import them after the upgrade.


#3

Ah, thank you very much! I thought it had something to do with silverblue and so I did not look into the podman issues.

The odd thing is that I am running podman 0.10.1.3 and as reported the issue seems to only affect 0.11.*. I guess I will just wait for the next upgrade and then I will see if things are fixed.


#4

I just noticed that fedora-toolbox uses a volume mount --volume /run/user/1000:/run/user/1000 and so it could mean that this somehow breaks the database.