Error: Could not find the Qt platform plugin "wayland" in ""

I am on Fedora 38. I am trying to run an AppImage Qt application on Wayland. By default, this doesn’t happen, so I tried

export QT_QPA_PLATFORM=wayland

This then causes the following error: qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in "". A common advice on how to handle this error (although found mostly on some Ubuntu-related forums, so maybe the things are slightly different there) is to install the packages qt6-qtwayland and qt5-qtwayland. However, both packages are indeed installed on my system. I have tried reinstalling them, but this didn’t help. Is there anything else I should try?

Which app are you having problems with?
If we could test it then we might be able to provide better advice. Without that it is like throwing darts in the dark

The app is Sioyek. Here’s the link:
My impression is, reading some of the advice on this error, that installing qt5-qtwayland should make some wayland-related plugin appear in /usr/lib/qt5/plugins/
But this doesn’t happen for me, I think, there’s only one plugin in this directory, it’s named kf5.