Qt app theme in gnome

I updated to Fedora 39 workstation (gnome)
I knew the theme for qt apps was going to be removed
The qt apps don’t look good , some are hard to read
So researching this is what I did
I put this export QT_QPA_PLATFORMTHEME=‘gnome’ in a .profile file
Bingo qt apps are pretty again
It worked in X11 and Wayland
Then I learnt I could put this in the bashrc file, and it worked in X11 and Wayland
If I use instead export QT_WAYLAND_DECORATION=adwaita it does not work in ether file on X11 or Wayland
Since QGnomePlatform is no longer maintained and I assume will stop working at some point, my question is where do I put the export QT_WAYLAND_DECORATION=adwaita?

Side note
I had one app that did not work properly in Wayland
So I put this env QT_QPA_PLATFORM=xcb in the programs .desktop file in the Exce line
So I can now run on Wayland

QT_WAYLAND_DECORATION only affects decorations (i.e. titlebars), which are specfic to Wayland with client-side decorations. qadwaitadecorations-qt5 is still installed by default. You should probably also install the -qt6 version if you’re using any Qt6 apps.

To my knowledge, there is no replacement for adwaita-qt/QGnomePlatform for styling the actual UI of apps.

To help understand what the problem is, can you provide screenshots of what these apps look like by default?

2 Likes

Here’s a couple of apps with and without
Avidemux doesn’t look to bad but looks a lot better with QT_QPA_PLATFORMTHEME=‘gnome’ and MKVToolNix looks a whole lot better




I believe that is Qt’s default Fusion theme, with colors pulled from GTK3 using Qt’s builtin gtk3 platform theme. The brokenness in MKVToolNix only happens when the gtk3 theme is set to Adwaita-dark. By default, it seems to ignore the system color scheme and stay in light mode.

Hopefully the QT_QPA_PLATFORMTHEME=‘gnome’ will keep working indefinitely
It makes the Qt apps so much nicer to use and look at
But I assume it will eventually stop working
It’s sad it’s not maintained anymore
At lease I am on Wayland now after fixing the one app that didn’t work

is the QT_WAYLAND_DECORATION=adwaita enabled by default?

That env var isn’t set, but I think QAdwaitaDecorations should be used automatically in GNOME. You can see it in effect in all of your screenshots.

That’s what I thought because I could not see any deference when I put it in the bashrc file
Thanks for your input