Error at installation


Goodevening everyone,

I made a bootable USB stick with Fedora 37 using Mediamaker (as preferred).
Fedora starts up normally from USB, except from a error about a missing file(?) dracut-pre-udev.

I start it up from the Windows boot manager. My Windows version is Windows 11 pro.

As said Fedora does start up in " try-out-mode" and offers the possibility to installl it.

During install I shrink my Windows allocated, shrinkable memory bij 100GiB, so enough space for installation. The installer stops right before copying files to the HDD I guesssed as it seems to be a memory error?

I tried a lot of obvious (non-linux) tweaks like ,clearing the memory again in Windows disskmanager. I can’t get Fedora installed.

Kindly and humbly ask for advice

kindest regards,


In English, “memory” usually means random access memory used directly by the CPU while disk space is used to store files. Rsync error 11 usually means the target disk is full. The installer may not have been able to “steal” the requested 100GiB from Windows.

I always make free space before running the installer to avoid such unpleasant surprises. There are multiple linux tools that can display and manipulate partitions. Try gparted (you may need to install it if it is not present in the live system). This will confirm the theory that
the linux partition created by the installer was not the full 100GiB.

In the past, I have been able to make free space using the Windows tools when linux tools failed, and even when linux tools worked, Windows still wanted to run chkdsk when next booted. Use Windows’ Administrative Tools/Computer Management/Storage Management to shrink its own disk partition.


Thanks for your response! I created the space for the installation in multiple different ways. I agree that the installer seems not capable of occupying the available space. Could this have to do with a former Debian installation or remnants of that uninstallation?

And how about Gparted? Is that an option? Installed it, but cannot clear the partition as it is occupied en running the Fedora live env…

Pls help, thanks for the efforts

Can you show us the exact message from gparted?

My guess is that the windows partition can’t provide 100GiB continuous free space. Have you done disk cleanup in Windows? Once I had a similar problem where the user had deleted a lot of files and Windows was showing ample free space, but would not shrink the Windows partition (using Storage Management) until the “Recycle Bin” was emptied. Disk cleanup has a “system” mode that will also remove old update files, etc. One more reason it is more efficient to use Windows tools to create free space for a linux install.

One step further, made a complete new install of Windows and tried again.

Nothing, same problem persists…

Did you tell windows to leave space for linux when you did the install? If not, how are you trying to make space for Fedora?

A “fresh” install of Windows should require multiple reboots while it applies updates and needs cleaning before trying to shrink the Windows partition. Many Windows 11 users (myself included) have had multiple update failures this week. Some say Windows is not properly registering installed updates. The problem updates are all from Intel and Dell.
I already have linux installed, but my Windows partition is now using more space than it should, even after the normal post update cleaning. I did find multiple copies of one Windows 8 library from Western DIgital that Microsoft still installs in Windows 11 even though it is never used.


Had the exact same issue yesterday with the installer. Tried a few different methods but sadly with no success.

The installer is able to create 2 partitions in the empty space allocated for the fedora install. It should be creating 3 partitions tho.

May be an bug within anaconda. Maybe its sizing the partitions wrongly. Maybe an gb vs gib issue… not sure.

I’ll try to install it again later today but manually sizing the partitions and give you feedback.

Best regards!

If you don’t disable fast boot in Windows, I think you have to do so before partitioning the disk. For that, you can follow this link:

1 Like

Ok thanks, in the meantime I found another distro to use. It installed quite easily.

Thanks for your reply

Kindest regards,

Bertus ten Hoor

1 Like

What did you end up choosing, if you don’t mind sharing? Nobara?

No, debian bassed Parrot os

1 Like

I’m kinda hell bent into installing fedora, but if anaconda decides not to cooperate I’ll have to look closely into other options.

Anaconda doesn’t decide anything, but it is designed to avoid breaking existing installations. If there are issues with anaconda it would be nice to understand exactly what is going wrong so anaconda can be improved. Having said that, my colleagues have often encountered problems freeing space for linux installs on systems with existing Windows installation. I find it best to use Windows tools to shrink the Windows partition to make space. If there are other existing linux partitions needing cleanup I run gparted from whatever Live Linux distro that comes to hand.

Have you encountered the same issue reported by Bertus ten Hoor?

Hi George,

You know what i meant there.

I didn’t encounter the same specific issue regarding cleaning the partition.

Thanks for the attention and patience!

Best regards.

Diagnostics for storage/partitioning and memory:

lsblk -p -o +FSTYPE,FSAVAIL; free -m
1 Like

It got me very aggressive during a week of trying and retrying. I even made a total clean install of windows several times……just to prove it wasn’t my fault…. In the end I gave up and got into Parrot. I don’t want to harm Fedora, their interface looked amazing too!

1 Like