Endless boot "A start job is running for Import network configuration from initrams"

Hello to all
I have a computer with windows and fedora 34 installed in dual boot. I never had any problem with fedora, but since a few hours, after using windows for a few days, I can’t launch fedora. The loading is infinite and when I press my F1 key, I just have this following command displayed with an endless timer. I did not find anything by typing the command on Google. Can someone help me?

Hi brouskaol,

Are you able to boot using any of the other GRUB entries? If you’re not, then I guess there are only two options left:

  1. Try to boot into recovery mode, for which you’ll need to modify the GRUB entry (I don’t recall doing so ever with systemd, if you’re stuck here let me know and we can both take a look at it)

  2. Boot from some other distro, especially a “rescue” distro like https://www.system-rescue.org/ or https://grml.org/), mount your root system, check the logs and see what’s happening there

Let me know how it goes!

Hi, thanks a lot for this quick answer!
I didn’t mention it but I’m totally new to the fedora environment and linux in general.

I tried to run fedora on all the grub entries posted, in all cases I got an endless load. If I’m not mistaken and that’s what you’re referring to when you talk about “rescue distro”, last night after posting the topic I tried to let it load all night on the rescue entry,(highlighted on my picture), no more change.
I don’t know how to boot in “recovery mode” (isn’t it the same thing ?), in the same way as a perfect beginner I don’t know how to mount my root system and check the logs. I would be really grateful if you could explain me step by step as I can’t find a tutorial (I probably don’t have the right way to search)
Thanks in advance

also i don’t know if it’s usefull or if it helps to understand my problem but here is the fail message I got when I let the boot run all night :

Hi Lisag,

Thanks for the picture, it definitely helps understand what’s going on in your system.

Usually udev errors (udev - Wikipedia) are associated with devices not working properly, misconfigurations or bugs.

I did a quick search and found that there is a known problem in Fedora 34 with a certain version of the kernel, which was corrected and fixed on a later release. We don’t know if this is your case, but let’s keep that in the back of our minds as a possible reason.

You mentioned you were unable to boot using any of the entries in the boot menu. It’s been a while since I used the traditional Desktop edition of Fedora (I’m using Silverblue, which aims to mitigate the kind of issues you’re experiencing), so I don’t remember how the rescue entry is configured; we can try tho to manually set the boot target to the rescue mode and see how it goes.

For that, you’ll need to temporarily edit a boot entry (let’s use the 5.15.5 one) to add this parameter at the end of the linux line: systemd.unit=rescue.target. If that works, you should be able to boot into a (text) rescue mode where we can start digging into what’s going on there!

An alternative would be to use systemd.unit=emergency.target if the above fails, to try to boot into a minimal emergency mode.

Take a look at his section in the official F35 documentation for precise instructions on how to edit the (GRUB) boot menu: Working with the GRUB 2 Boot Loader :: Fedora Docs

If forcing booting into Emergency Mode fails, then the only way to try to get access to your system would be to boot from another system – what I meant when I said “boot from another rescue distro” in my first answer.