Encrypted file system not mounted on boot? cryptsetup issues? Known issue in SELinux-policy - Please check existing bug report before filing a new one

Currently, there is an issue in the package selinux-policy that was introduced with the update to 40.22-1 (at least on F40).

If you experience issues with regards to SELinux denials, primarily with encrypted file systems that are not mounted on boot (or cryptsetup issues in general), please check if your issue is maybe the following:

https://bugzilla.redhat.com/show_bug.cgi?id=2292191

If you have this type of issue, feel free to report there how the issue manifests in your case, if it differs to existing posts. Otherwise you might just CC yourself in the bug report. But avoid filing new reports for that very issue.

If you are unsure, feel free to report your manifest here first. Feel also free to ask questions here.

It seems several people currently open bug reports about that, which can increase the time until the issue can be solved.

The existing report contains means to mitigate the issue until it is solved with one of the next updates.

Thanks to @zpytela for his contribution :wink:

3 Likes