Enabling SmartCard in Firefox: Can't access DoD websites

Sorry in advance for my lack of understanding of how these certificates work and being very new to Linux.

I’m in the Navy reserves and need to access DoD websites that require a smart card. I read Firefox was already supposed to work on Fedora 36 using opensc, but I have still run into issues. Most of the tutorials to fix this are older before Firefox worked out of the box.


  • I was able to download and upload the authority certificates but when I tried to add a security device (opensc-pkcs11.so) it errors saying unable to load module.

  • I’ve tried reinstalling Fedora/Firefox.
    pcsc_scan detects the card being inserted/removed so I believe my drivers work.

  • My CAC card is able to access DoD websites on my windows desktop using edge and firefox.

If anyone can lead me in the right direction to fixing the issue I would greatly appreciate it.

In order to get more people to read this topic I suggest you change the title to something like “Enabling SmartCard in Firefox”; that way you can tackle the cause and not the symptom :slight_smile:

opensc-pkcs11.so is provided by the package opensc.

I updated the title to reflect the issue correctly.

1 Like

hello, I am in the Army and I am having the same issue. pcsc_scan does not detect my card reader on top of the firefox issue. Did you get it to work by eny chance?

I was able to get this working by installing opensc and the certificates in Firefox.

I’m using SCM Microsystems Inc. SCR 3310 [CCID Interface] for a card reader.

my card reader is ZOWEETECH. I am a long time archlinux user and I got it to work just fine. I also tried it on linux mint and windows 11. I recently switched to fedora and for some reason I can get it to work.

1 Like