Dual boot Windows and Fedora, after rebooting from seconday OS (Fedora) it directly boots to pimary OS (Windows) without Grub showing

I am running a laptop with dual boot Windows 10 and Fedora 40. Grub works as it should. Whenever I boot my laptop, it appears no problem on boot. I have Windows as my default entry for grub. Whenever I reboot from Windows to Windows again, it works flawlessly. The issue consists when I reboot from Fedora, and grub doesn’t come up but boots directly to Windows. It always does this. It acts as some sort of cycle. Where after booting to the second OS, it wants to boot to the primary without asking.

I have tried for a while now to tweak settings in the grub, but to no success. I managed to fix this issue once when I installed a theme on grub, but didn’t understand how I fixed it. To my avail, thinking I wouldn’t touch grub again, the next kernel update it rested it as it was.

I have tried to make Fedora as my primary entry and the same happens to the Windows in this case the second OS, after rebooting it grub won’t show and would boot directly to Fedora.

I haven’t seen any other topics regarding this problem to any other OS. I am still a beginner trying to figure out Fedora, I have a couple of months searching for a solution but to no avail.

Looking forward to hearing your advices and experiences.

Kind regards!

I have to wonder how you set windows to be the default for booting.
On every dual boot system I have used the default has always been the latest installed fedora kernel.
The grub menu is normally displayed by default during boot as well when dual booting and is hidden when only fedora is installed.

The content of the grub env file can be seen with sudo grub2-editenv - list.
A user may unhide or hide the grub menu by setting it within the environment file using sudo grub2-editenv - unset menu_auto_hide or sudo grub2-editenv - set menu_auto_hide=1.

The system can be configured to save the most recently used boot entry as the default by editing the file /etc/default/grub and adding the option GRUB_SAVEDEFAULT=true at the end of that file, followed by sudo grub2-mkconfig -o /boot/grub2/grub.cfg. This then would add the variable save_default=true into the output of the list from the grub env file shown above.
When doing so, now the system always saves the last booted kernel/OS as the default for the next boot. Setting the default in this way means that to change the default it is only necessary to select a different option from the grub menu (which means the grub menu has to be visible).

My guess would be that the BIOS was used to boot windows directly.
Is that the case @doodle ?

Choosing Fedora in the BIOS will get you to the grub prompt.
Edit: and from the grub prompt you can pick fedora or windows,