Dual boot, can't boot to Fedora anymore


I’m using a dual boot machine: Fedora 31 and Windows 7. Today I’ve tried to upgrade Win7 to Win10, but it failed (not as smooth as a Fedora upgrade… but what can you expect). The system reverted to Win7. It doesn’t matter, I’ll probably do a clean install of Win10 on the partition Win7 used to be. However, the problem is that now my grub menu is gone. My PC boots directly to Win7.

So my question is this: After I’m installing a fresh Win10 over Win7, what should I do to get my old grub-menu back, so that I can log in to Fedora again?

P.S. I am using my Windows boot for gaming, and Linux for the rest.

🛸️ vits95

And this will happen to anyone! Time to choose the side!!!

Load an Live DVD/USB.
Try to install/reinstall grub.
There is

1. Fedora Wiki (GRUB 2).

2. \:smirk_cat:-? When If above didn’t helps, try Arch Wiki (GRUB). After updates menu should become beautiful again.

With the help of the wiki and a few other forums, I’ve managed to re-install grub2-efi.

All back to normal now.

Ch. Norris in disguise: Solved, twice!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.