GRUB doesn't boot Windows anymore

GRUB isn’t loading Windows 10 anymore after the recent update.
I saw there was the recent grub update to fix this issue, but that didn’t seem to work for me. (Maybe I’m installing it wrong?) I am on Windows 10, and all the posts I see talk about Windows 11.

The posts I saw were:


Seems to be the same issue on my end, where I can boot to Windows through the Boot Menu, but not through GRUB. It hangs on the boot and gets stuck.

Any advice is appreciated.

Thank you.

I think I figured out my issue. Documenting in case anybody else comes across this.

In the update documentation, the update to fix the issue was given the command:

sudo dnf upgrade --refresh --advisory=FEDORA-2022-d0c322d15a

I read through the original bug report again:
And after scrolling down, it seems that the command that worked for me was listed in there:

sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-d0c322d15a

That command worked for me but not the other.


The first command seems to have missed the need to enable updates-testing in order to work.

If you already have that repo enabled then it would work, but if not then the extra option is needed.

Yeah, I didn’t think it needed to be enabled because in the documentation it seemed that the update was marked as stable and was pushed out already.