Downgrading to Fedora 34 - Where should I download the iso and the checksums?

Hi everyone,

I decided to move to Fedora a few days after 35 was released. Unfortunately, I am/have been experiencing some annoying issues, for which I have filed a bug report. To be fair, most of them have already been fixed, except for a very annoying one, where tracker-miner-fs-3 crashes my computer by using all memory right after startup, unless I kill it. I am also wary of any new issues I might discover (I haven’t installed all the software I usually use yet).

This isn’t ideal, as this is my daily driver, so I want it to work flawlessly without having to think about it.

I am thus considering installing Fedora 34 instead (the standard workstation, with GNOME), so I have two questions related to that:

1°) Can I reasonably expect to have a better experience with 34 than 35? I assume that it’s been out long enough that the main bugs have been fixed. I’m on a XPS 13 9343, not a niche machine. NB : current install is Xfce spin, but I’m keen on trying GNOME this time.

2°) Where should I download the iso and the checksums? I have found two ways to download the iso so far: the first one is which I trust as it is accessible straight from the getfedora website. Unfortunately, I have never used torrents so this is not ideal for me. The second one is Home - MirrorManager but there are a lot of mirrors, not sure which one should I use, etc…
What would be the most common and practical way to get Fedora 34 iso + checksums here?

Thanks for your help!

1 Like

“Index of /pub/fedora/linux/releases/34” Index of /pub/fedora/linux/releases/34

The checksum file is alongside the ISO file.

1 Like

Perfect, thanks! Not sure why this didn’t turn up during my searches.

1 Like

Works just fine with your torrent client (deluge, transmission etc.)

1 Like

Hello @ratapenada ,
Welcome to the :fedora: discussion area. Sorry to hear you are having such difficulty with F35. Perhaps (if you did a default install) you may want to create a swap partition on your system that is about twice your ram size, and enable it since this could be an early OOM crash. Though to know a few details would help. You can see your swap strategy with the command swapon --show, on my system for instance it show’s

/dev/sda3  partition 5.8G   0B   -2
/dev/zram0 partition   8G   0B  100

because I have swap on disk and zram, I run 32Gb of ram. The swap partition on zram was setup by Fedora Linux during install at that size, I added the disk swap partition during the install in the advanced storage configuration (advanced Blivet GUI). Anyway I think earlyoom killer is plaguing you as a first glance guess. I would need more info about the errors you are getting, and a link to your posted issue would be great!
I run Fedora Linux Rawhide Silverblue, so the immutable OS. You should see if it can coer your use case, it is very stable and affords a level of confidence in stability you don’t “feel” with standard workstation. For example, if I do an upgrade an it borks my system, I rollback the system to the last known good working state and either try again or wait for the fix to come so I can try again, I am never left with a broken system unless I am fiddling. This is done with a simple one line command I can enter as a user, not even root.
rpm-ostree rollback

1 Like

Hello @jakfrost, and thanks for the detailed answer!

Regarding swap, I believe I haven’t created any myself, as I didn’t go into the advanced config during install. Here is what swapon --show is displaying on my system:

/dev/zram0 partition 7,7G 1,8M  100

Here is where I posted the issue. From what I understand, tracker-miner-fs-3 is used for indexing. It is trying to index all the files I’ve copied at once (around 80k files) from my old laptop, which is causing the memory leak. It wasn’t happening when I was using the laptop with only a few thousand files transferred. Maybe a bodgy fix would be to copy the files more progressively on a new install, and restart the computer after each transfer.

Thanks for mentioning Rawhide Silverblue, I heard about it and will definitely try to learn more, but right now time is of the essence for me, so I’d rather stay on the more standard solution, Workstation.

@hamrheadcorvette: never used torrents before and right now I couldn’t spare the time to look into them! But thanks for mentioning clients, I will learn a bit more when I have less things on my plate.

It looks like you have identified it. I just am still having a bit of a problem on why. I regularly copy/move large amounts of data around, I image customers disks all the time, and aside from physical disk issues, I have never crashed on files copying or disks being imaged. So even with a first time install I can’t reconcile what happened to you as simply a result of file indexing. Maybe I am mistaken though. I think, on a related note, that Fedora is changing the backing of locate from mlocate to plocate?