Does the grub menu appear by default on single-boot Workstation installations?

Yes and no, if you don’t have a dual boot system, grub menu with kernel entries won’t be shown …

I have two Fedora hosts (one was installed with F33 or F34, the other with a release several years ago) and a few Fedoras in VMs, the latter containing one that was installed with F36: I have the grub menu with the recent three kernels for 5 seconds by default on all of them. All machines/VM only contain one Fedora. However, all installations I currently have are Workstation or KDE spin. So I don’t know if the default config of Server or the rpm-ostree editions are different.

It looks like,
There the OP mentions he has to select the new installed kernel every-time he updates.

Somehow makes sense. If you change kernel you sometimes want to check before go live with it.
If there is a problem and the system not starts, you have to fiddle before your system runs again.

In the other hand, if it not gets changed be apply a kernel update, you just have to restart the system and it should work again. By maintenance you gain a lot if time this way.

The article notes that you can still get the grub menu with SHIFT. So even single boot systems can revert to older kernels without manual changes to the grub config or so. But I cannot confirm even that. I have the 5 seconds grub menu on all systems by default. I’ll check in the devel mailing list.

1. Single OS test
    1. Install Fedora Workstation in a fresh vm or select reclaim diskspace -> delete all in the installer (do a single os install).
    2. Boot the system the grub menu should not show
    3. (Re)boot, hold the left SHIFT key down during boot, you should now get the grub menu

I doubt that this is widely known.

Agreed. That’s one of the reasons why I would be no fan of the need to use SHIFT to get into the grub menu. However, I am not convinced if the article is up to date at all. As I mentioned, I do not experience this behaviour on any single boot system. Do you had it on any system by default? If so, with which release was that single boot installed? I’ll let you know if I get a feedback from the mailing list.

Supplement: I have split the topics because the other topic is already solved by dnf update & reboot.

My comments are only about Workstation since I have not been using other spins.

I do not remember when the default was changed to hide the grub menu. It seems it may have been about 32 or 33, and when it happened I manually made changes to revert to the displayed grub menu during boot.

There were some discussions at that time about it and several posts subsequently told users about using the shift key to display the grub menu.

I think that about 35 it was reverted back to having the grub menu displayed by default. At least on a new clean install of 35 or 36 the menu displays. I have not done a clean test install of other releases to verify where the changes occurred.

1 Like

Well, read yourself:

It became split into two different threads.

Feel free to contribute, my opinion does not aim to be representative for ask.fp or so. Obviously, there is much probabilism in this topic.

1 Like

Yes, I do see that behaviour on my laptop (single boot) and a VM, by default, no changes to the settings by myself.
Not exactly sure when I installed Fedora on the laptop, probably using F33 or F34 (not near that machine right now).
The VM is a couple of weeks old (F37 beta).

That matches what was said here:

1 Like

If you reboot from a terminal application or virtual console you should see the grub menu on reboot.

It is documented but like the shift key how many read through the notes.

On a side note may want to consider just using grubby to set a new default kernel for instances such as this instead of using the grub menu.

List all boot entries
sudo grubby --info=ALL

Display the full path to the default kernel
sudo grubby --default-kernel

Switch default kernels
sudo grubby --set-default="/boot/vmlinuz-5.19.11-300.fc37.x86_64"


I go to grub menu by clicking esc when booting

It differs between different firmwares. This is one of the problems. The wiki page is not up to date: it is not always SHIFT. See the discussion in the mailing list.

1 Like

thanks for hint
i didn’t know about it