Dnf repositories issue in fedora 36beta

I don’t know what happened but i can’t update stuff with dnf command. It always shows all dependency resolved and meta data synced but it is not i can install updates with softwarecenter. Here is a screenshot. and the worse part of gnome software center is it does not show the update size for software update.

active repos are here

Try forcing dnf to update its cache and check if it fixes the issue.

sudo dnf upgrade --refresh

I would also suggest that the gnome-software update cache is out of date and should be updated.
sudo pkcon refresh force


whenever i want to update it only sync 2 repos but previously it was 6or 7 repos synced i dont know why maybe some days ago i tried to install protonvpn repo and then deleted that repo but this a issue i am facing look into it
Screenshot from 2022-04-18 23-16-43
kindly look into my repos that i added in this post does everything right like some are disabled i didnot do that i am in beta f36 rtn.

yes i can do that with force but in general dnf update does not sync all repos as it was before.


Fedora 36 is still in beta. Thus the only repos that are absolutely certain to be relevant are the ones for fedora 36.
These are the ones I have

 $ dnf repolist
repo id                                                repo name
fedora                                                 Fedora 36 - x86_64
fedora-cisco-openh264                                  Fedora 36 openh264 (From Cisco) - x86_64
updates                                                Fedora 36 - x86_64 - Updates

I have disabled the modular repos (fedora-modular and updates-modular) on my system but otherwise this should be the default config for repos with fedora 36.

What is the output for dnf repolist on your system?
Which repos shown in dnf repolist -all that are disabled do you feel should be enabled?

You can enable or disable any or all of the installed repos in that list with
sudo dnf config-manager enable <repo id>

The commands given above get info from and act upon the /etc/yum.repos.d/*.repo files on your system

1 Like

Maybe there’s some issue in dnf config /etc/dnf/dnf.conf? DNF Configuration Reference — dnf latest documentation

Try to clean-up meta-data and run dnf in verbose mode, maybe distrosync will revert some faulty update:

dnf clean all
dnf distrosync -v

Can we request you to paste text instead of pictures please? Pictures cannot be searched, and they’re not accessible to users that rely on screen-readers etc. to use the forum also.

(Pictures should only really be used to show screenshots. All command output should be pasted as text.)

1 Like

sure that was my mistake

[insas@fedora ~]$ dnf repolist
repo id                                        repo name
brave-browser-rpm-release.s3.brave.com_x86_64_ created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/
fedora                                         Fedora 36 - x86_64
fedora-cisco-openh264                          Fedora 36 openh264 (From Cisco) - x86_64
fedora-modular                                 Fedora Modular 36 - x86_64
google-chrome                                  google-chrome
phracek-PyCharm                                Copr repo for PyCharm owned by phracek
rpmfusion-nonfree-nvidia-driver                RPM Fusion for Fedora 36 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                        RPM Fusion for Fedora 36 - Nonfree - Steam
updates                                        Fedora 36 - x86_64 - Updates
updates-modular                                Fedora Modular 36 - x86_64 - Updates
1 Like

when i use dnf update
it syncs all repos like this

[insas@fedora ~]$ sudo dnf upgrade --refresh
[sudo] password for insas: 
Copr repo for PyCharm owned by phracek          2.1 kB/s | 3.6 kB     00:01    
created by dnf config-manager from https://brav 4.7 kB/s | 3.3 kB     00:00    
Fedora 36 - x86_64                              3.7 kB/s | 5.5 kB     00:01    
Fedora 36 - x86_64                               19 kB/s | 1.7 MB     01:32    
Fedora 36 openh264 (From Cisco) - x86_64        609  B/s | 989  B     00:01    
Fedora Modular 36 - x86_64                      3.7 kB/s | 5.5 kB     00:01    
Fedora 36 - x86_64 - Updates                     49 kB/s |  41 kB     00:00    
Fedora Modular 36 - x86_64 - Updates            2.0 kB/s | 5.3 kB     00:02    
google-chrome                                   1.4 kB/s | 1.3 kB     00:00    
RPM Fusion for Fedora 36 - Nonfree - NVIDIA Dri 2.9 kB/s | 5.6 kB     00:01    
RPM Fusion for Fedora 36 - Nonfree - Steam      4.0 kB/s | 5.4 kB     00:01    
Dependencies resolved.
Nothing to do.

but now using same dnf update it only sync 2 repos

to sync all repo i need to force

That’ll just be because the metadata has not yet expired, and so dnf does not need to update all repo-data again. dnf also has a timer in the background that updates metadata periodically, so it’s quite rare to have to force dnf to update its metadata.

What fedora-release and fedora-repos package versions are you on? If you’re on the newest one, updates-testing has now been disabled for users.


Since we’re in the final freeze, you will receive updates once they are pushed to the updates repo as usual—a large batch of zero day updates. There are just not that many updates in the pipeline:



If you want to continue receiving updates in the meantime, you’ll need to enable the updates-testing repos.


If you would like to check what updates are in testing you can run
dnf update --enablerepo=updates-testing,updates-testing-modular
That will enable testing once so if you wish to update whats in testing you can.I usually run that every few days until the release then just use
dnf upgrade --refresh.


I tried dnf update after 5days it should be expired
Before my proton stuff that i have done it always checks and sync after 1or day or so if i ask for dnf update

That could be possible that is why i have added screenshot of repos kindly see them on my first post screenshots are there.
I am on f36beta fully updated till yesterday
Kernel and gnome 42.

No that is okey just see if everything alright .if it was done through a update that is okey. You will understand just check out my first post.

Yes, but it is also automatically updated from time to time using the dnf makecache timer:

$ sudo systemctl status dnf-makecache.timer 
[sudo] password for asinha: 
● dnf-makecache.timer - dnf makecache --timer
     Loaded: loaded (/usr/lib/systemd/system/dnf-makecache.timer; enabled; vendor preset: enabled)
     Active: active (waiting) since Sun 2022-04-17 16:21:32 BST; 1 day 23h ago
      Until: Sun 2022-04-17 16:21:32 BST; 1 day 23h ago
    Trigger: Tue 2022-04-19 15:43:40 BST; 7min left
   Triggers: ● dnf-makecache.service

Apr 17 16:21:32 raam systemd[1]: Started dnf-makecache.timer - dnf makecache --timer.

The expiry also depends on the configuration—have you modified any dnf or repository configuration files recently? (directly or indirectly)

And, it also depends on whether the repos have seen any changes----at the moment, the Fedora 36 repos are not seeing new pushes.
Is the

I meant:

$ rpm -qa fedora-release\* fedora-repos\*


I don’t see anything wrong with your repos. I’ve only had the kernel update as well in the main repo.Thats why I suggested the testing repo as it has the updates that will move to the stable.


Thanks i will see if it was a wrong panic i will update in 3-4 days i will observe if all are okey or not.

it seems solved dont know does that happened maybe with an update or i have disable one by one and re enable them which solved today i noticed everything is right how it should be.

1 Like