Dnf errors and need auth too much and i don't know why

every time i see authentication is needed to run /usr/bin/dnf as superuser error and it’s too much
what is happening??


You need run with sudo, so for example:

sudo /usr/bin/dnf update

Thanks Tom.

it happens when i am working with os
not when i want update os
few days ago dnf and yum updated in system
after that it happens always


Can you please provide a screenshot showing the error?

Thanks Tom.

it always come and i don’t know why?bug???

That popup says you need to enter your user (sudo) password so dnf can run for you.

That should always popup if you, as your regular user, attempt to run dnf to do anything with the software. The only time it pops up is if a regular user tries to run dnf without using sudo so that tells me you are entering the dnf command which then triggers the popup. This is not a bug, but design, and the fix is to always use “sudo dnf …”, or just enter your password there as prompted.

Dnf always needs to run as the super user in order to make software changes.


thanks for your reply

it’s correct that you say man

but it appears every 20 minutes is it possible?

If you are doing something with dnf that often then yes.
Also if somehow you have the system configured to do an automatic dnf update as your regular user that often then yes.
Did you maybe create a crontab entry to do the update for you?

“sudo dnf history” can tell you how often dnf has run and what the command was each time.

only my commands appears nothing else

You said it appears about every 20 minutes. Are you actually running dnf that frequently? If so, why?

It appears you have many extensions installed; are you sure it’s not one of them?


So is this extension look like??

Thanks for your answer
No man i run dnf update every week

In Fedora Linux Updates Indicator you likely had “Check updates without password” ticked, but Fedora was like “No man, you need the password to check for updates!” and so the prompt kept popping up asking for the password. But, if you just leave that option off you’ll be fine. But 3 years later you’re likely way past this issue.

Topic is 2.5 years old, let’s close it and rather open a new if issue re-appears.