Dependency failed for dev-zram0.swap

I uninstalled my nvidia driver using the .run file I used to install it with.
sudo bash ./NVIDIA*.run --uninstall
I also set my target to multi-user after uninstall.

However when I boot now I get the following errors…


Here is my grub configuration…

I remove rhgb quiet to boot and view the details of the errors.

I can not even get into a TTY session to debug reinstall, etc.
Is there a way out of this mess, is there anything I can try.

Any advice is appreciated.

In grub, try to add selinux=0 to the linux line. And also remove rd.driver.blacklist=nouveau
Let’s see if it boots successfully, if it is the case, we can continue to solve the issue.

The recommended way to install NVIDIA driver is from rpmfusion, see Howto/NVIDIA - RPM Fusion

1 Like

That wont work for him as he didn’t use rpmfusion.

Hello @exist2resist ,
Perhaps a look at the bash file you used to uninstall can give some clues as to what it may have done when you selected the --uninstall option. If it’s not too large you can post it here as preformatted text (</>)

Adding selinux=0 to the grub boot option fixed my issue. Interestingly enough I did have that set in my grub file located in /etc/default/grub. I just forgot to run sudo grub2-mkconfig -o /boot/grub2/grub.cfg.

Why would this happen all of a sudden, is it because I forgot to rerun the grub config and that entry was in the file?

Last time I used rpm fusion, post upgrade from F39 to F40, it broke my system.
So from now on I’ll stick to the official driver from Nvidia.
Additionally I found that using rpm fusion for the driver installation, hardware acceleration for certain applications such as OBS was spotty, whereas with the official driver it worked.

Wait. Did you disable selinux permanently?
Because you can perform a relabel of the filesystem and at the next boot look if the system start correctly, and eventually keep selinux enabled.

3 Likes

I didn’t before but did now. T
he system will not boot without that option even after reinstalling the driver.

Looks like there is something seriously wrong with my system, it is locking up on me. With or without selinux enabled.

So.
Try to boot with selinux=0. Once booted, issue this command
sudo touch /.autorelabel
And reboot.
This should fix the messed up selinux policies.
So the system should start again to work with selinux enabled.

The file was already there, still ran the command…
and get the same result. Os fails to boot.

Alright fixed now.
Boot with selinux=0
I had to first set the selinux mode to permissive in the config file /etc/selinux/config, then sudo touch /.autorelabel, rebooted and the os relabelled everything.
Following that I was able to boot into the os and set the mode to enforcing.
Following reboots work now.

2 Likes