Dell XPS 7390 Graphics Problems


Long-time *nix user, first time Fedora user. I recently got a new work laptop (Dell XPS 7390) and have been having a horrible experience getting any distro to run on it. Horrible graphical glitches in Ubuntu 19 (On GNOME, XFCE, with gdm, with lightdm, etc.) , inoperable wifi on Elementary 5.1 (even with backported Killer drivers), etc. I ended up on Fedora 31 because it comes by default with one of the newest kernel releases. And I had tracked most of the problems that I was having to the *buntus having older (<5.0) kernel versions. Apparently the Comet Lake i7-10710u in the XPS 7390 and its associated display and wifi modules are not supported in older kernels.

However, I’m still having minor graphical issues in Fedora. See photo attached. Anyone have any tips? Currently running stock Fedora 31.

This also doesn’t show up if I take a screen shot.

I posted the same question over at and was advised to try GNOME on Xorg, which I did, but no change.


Maybe your need some additional drivers?

Hm, thanks for the link.

I followed the instructions there (install intel-media-driver from RPM fusion, set LIBVA_DRIVER_NAME=iHD) and it doesn’t seem to help. Still having random graphical problems as before.

I’ve such troubles too, btw.  I can solve them by switching screen’s frequency to lower one, but it is an old external display, though.

Ah interesting!

Mine are definitely better under Fedora than other distros that I’ve tried. I’ve actually been able to complete work on my Linux side. So I’ll just plug away for now and hope that continued kernel updates improve the situation.

Good luck with yours!

This ended up being a problem with Panel Self Refresh settings for Intel integrated graphics. This can be solved by doing the following:
sudo nano /etc/default/grub
Edit the line that begins with GRUB_CMDLINE_LINUX, which already has many kernel args specified to have i915.enable_psr=0 at the end, so it will look something like:
GRUB_CMDLINE_LINUX="...many args... i915.enable_psr=0"
Save and exit the editor, then run:
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
and reboot.

Note that disabling PSR will have an impact on battery life. But the machine is annoying at best and unusable at worst if you encounter this problem.

# idk why, but
# the "canonical" way is:
EDITOR=nano sudoedit /etc/default/grub

Ah, didn’t know that! Found a good explanation here. Thanks!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.