Vaapi - vainfo init failed

I have recently moved from Arch to Fedora and am looking to get some hardware acceleration going, I have installed all the intel libva drivers however when I run vainfo I get the below error. I have tried adding and removing drivers one at a time but it always gives the same output, This did work with the same driver on Arch but I was wondering if this could be a version thing? as my CPU is rather new so maybe something somewhere hasn’t made it this far up stream, have any of you experienced anything like this?

$ vainfo
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/
libva info: Found init function __vaDriverInit_1_6
libva error: /usr/lib64/dri/ init failed
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

OS: Fedora release 31 (Thirty One) x86_64
Host: Razer Blade Stealth 13 Late 2019 2.0
Kernel: 5.4.12-200.fc31.x86_64
Packages: 1858 (rpm)
Shell: bash 5.0.11
CPU: Intel i7-1065G7 (8) @ 3.900GHz
GPU: Intel Iris Plus Graphics G7


1 Like

source (github):
tsoernes commented on Jun 10, 2017:
libva-intel-driver was available in RPM fusion repo’s, installing it fixed the issue.”

It is recommended to take some piece of error (say, “vaInitialize failed with error code -1 (unknown libva error),exit”) and paste it to an Web-search engine (in quotes).

Edit: It is also recommended to read the Topic Starter posts at least twice, rather than just “advice” a first result from a Web-search engine to someone, who even had formatted their posts well.

I’m really sorry.

I have actually found myself all over google looking for anyone else having this issue the last couple days but came up empty. Unfortunately as per the Driver section on my post I already have installed libva-intel-driver-2.4.0-1.fc31.x86_64. I have tried reinstalling this but no luck. I have even this afternoon tried booting the live media and doing a fresh VAAPI install on that and get the same error, which eliminates any conflicts

Hi All,
After a few more hours tonight I have managed to crack it, it seems there are some issues with the new iGPU and the VAAPI driver however if you make sure intel-media-driver is installed then set the LIBVA driver to iHD with export LIBVA_DRIVER_NAME=iHD it starts working again

1 Like

Where to put this to make it work system-wide?

To make it system wide you just need to put LIBVA_DRIVER_NAME=iHD in /etc/environment

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.