Cups-2.2.12 breaks printing for me

My HP Officejet Pro 7740 had been working well with Fedora since Fedora 29 and continued to after an upgrade to Fedora 30. However, sometime in the recent past (no more than a couple of weeks probably a lot less) printing stopped working. Printing a PDF to the printer resulted in the raw PDF being printed rather than the pages. I tried to delete the printer and re-add it with the hp-toolbox from hplip, but while the delete worked, re-adding the printer caused “internal error” messages (even from the cups webpage) that after poking at a while seem to be ppd related. But I can’t be positive about that. What I am certain of, is that a “dnf downgrade cups” which reverted cups to 2.2.11 from 2.2.12 seems to have resolved the issues. The dnf downgrade reverted a handful of packages, so I can’t be sure where the issue really is.

  Running scriptlet: cups-libs-1:2.2.11-1.fc30.x86_64
  Downgrading      : cups-libs-1:2.2.11-1.fc30.x86_64
  Downgrading      : cups-client-1:2.2.11-1.fc30.x86_64
  Running scriptlet: cups-client-1:2.2.11-1.fc30.x86_64
  Downgrading      : cups-ipptool-1:2.2.11-1.fc30.x86_64
  Downgrading      : cups-filesystem-1:2.2.11-1.fc30.noarch 
  Downgrading      : cups-1:2.2.11-1.fc30.x86_64
  Running scriptlet: cups-1:2.2.11-1.fc30.x86_64
  Running scriptlet: cups-1:2.2.12-1.fc30.x86_64
  Cleanup          : cups-1:2.2.12-1.fc30.x86_64
  Running scriptlet: cups-1:2.2.12-1.fc30.x86_64 
  Running scriptlet: cups-client-1:2.2.12-1.fc30.x86_64 
  Cleanup          : cups-client-1:2.2.12-1.fc30.x86_64 
  Cleanup          : cups-ipptool-1:2.2.12-1.fc30.x86_64
  Cleanup          : cups-filesystem-1:2.2.12-1.fc30.noarch 
  Cleanup          : cups-libs-1:2.2.12-1.fc30.x86_64 
  Running scriptlet: cups-libs-1:2.2.12-1.fc30.x86_64
  Verifying        : cups-1:2.2.11-1.fc30.x86_64 
  Verifying        : cups-1:2.2.12-1.fc30.x86_64 
  Verifying        : cups-client-1:2.2.11-1.fc30.x86_64
  Verifying        : cups-client-1:2.2.12-1.fc30.x86_64 
  Verifying        : cups-filesystem-1:2.2.11-1.fc30.noarch 
  Verifying        : cups-filesystem-1:2.2.12-1.fc30.noarch 
  Verifying        : cups-ipptool-1:2.2.11-1.fc30.x86_64 
  Verifying        : cups-ipptool-1:2.2.12-1.fc30.x86_64
  Verifying        : cups-libs-1:2.2.11-1.fc30.x86_64 
  Verifying        : cups-libs-1:2.2.12-1.fc30.x86_64


Nice adventure you had there. It might be helpful to go through it again :wink::stuck_out_tongue_winking_eye:
Why would I suggest such? Well, the best way to get a permanent solution for everyone is to report the incident here. You’d need a bugzilla account though.

Select “cups” as the component and fill-out other fields. You will need to describe what you experienced – the more information you provide, the greater the chances of replicating the issue. Those messages you talked about would be extremely valuable. You can also state that a downgrade resolved it. That informs the maintainers that there may be a regression.