Crash after a few seconds

Hi, I recently installed fedora 34 and after setting up my device, in about 10ish seconds after booting up and coming to the login screen, no matter what, the computer will reboot. This does not happen on the live usb I have or my windows boot. Not sure why this is occurring.
Here’s the fpaste and if anything else is needed I’ll try to get it

It looks like that fpaste is from the live USB?

From that, I think you have an nvme, but I’m not sure what model? Probably a Samsung EVO? I think you may be hitting a power saver bug in the nvme. There may be a firmware update available for the drive that fixes it.

If not, you may be able to work around this by adding nvme_core.default_ps_max_latency_us=0 to your kernel command line. This can be done temporarily in GRUB or permanently with grubby.

If you aren’t already on the latest kernel, it may already have a quirk to disable this power saving mode, so adding that setting temporarily may be enough of a stop gap to install an update.

Just in case. From the fpaste line 204-205 and 211-212, look like there something wrong with module configuration in xorg. I’m not sure, but did you make any custom configuration related to xorg.conf? Most of the time by using auto generated configuration using nvidia-xconfig is enough.

So it’s actually neither of these issues. I went through the system logs and found a line on libvirt so I decided to try and unistall the packages using dnf remove libvirt-daemon and it worked. At the least, I’m not crashing, however I do want to be able to use a kvm. Is there any issues that ring a bell from this?

Welcome to ask.:fedora:edora @spruser1

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

So we do see how your System looks like without having to ask all the information.
If you not had time yet to read #start-here please do so.

I found out that having /dev/ in my storage pool was crashing my system when libvirt loaded it. Removing it fixed it. However, in the process of trying to do a single gpu passthrough, I think I unloaded my nvidia driver or possibly the card from being loaded. I don’t have integrated graphics so all I see when trying to debug the boot, is dracut starting to run its commands, something about vga decode, then all output is frozen. When I looked at the system logs from a live usb, it seems the system is still loading in, but it no longer has the gpu to load any gui or command line. Is there some way to reload regenerate dracut as I removed the problem confs but can’t get in any sort of shell to do so?

During boot you should be able to get to a single user screen by (during the display of the boot menu) press ‘e’ to edit the grub boot entries.
Then on the line that begins with ‘linux’ remove the part that says rhgb quiet and add 1 init=/bin/bash
Continue the boot with ‘ctrl-X’

This will get you into a root single user session where you can make the changes needed to restore the normal boot.

IME passing the GPU through to the VM removes it from access for the host so that seems a bad idea unless you have multiple GPUs.

Sadly this does not work as the gpu is probably being unloaded still. I get on boot to where it says dracut cmdline hook before all video input stops.

I’ve backed up all my files, I think I’m just going to reinstall sadly.