Fresh install of Fedora 34 crashes on second user setup screen

I tried to install F34 from a Live USB (created with Fedora Media Writer). The target is a new laptop (Asus ROG Strix G15 Advantage Edition), so I had to work around the MS encrypted Windows 10 volume. I did so by adding a second SSD.

The Fedora Live demo actually would not work except in basic graphics mode. This hints at a graphics problem, possibly related to the laptop hardware. However the installation did succeed in creating a bootable volume on the second SSD.

On first startup Fedora tries to create a user account with a brief sequence of setup screens. The second of this asks for a “real name” and allows one to enter a username for the home directory, etc.

This is where the system repeatedly crashes, after entering two characters of the real name or one character of the proposed username. The screen goes blank, then black, then eventually shuts down with no error displayed.

I’ve used Fedora (installed and upgraded on other PCs), so perhaps I will try installing an older version and doing a version upgrade. Other suggestions, esp. to identify the root of my problem, would be appreciated.

Which version of windows is installed there?
I have a slightly older (ROG Strix G731GU_GL731GU) 17" laptop which came with windows 10 and have had zero problems running fedora on it. One noticeable difference is you say the windows is encrypted and mine is not.

Also, what do you have for GPU?
Mine has an intel UHD Graphics 630 for IGP and an nvidia GeForce GTX 1660 Ti Mobile discrete GPU. By default the system uses the IGP, and the nouveau driver was loaded for the nvidia GPU.

With the nvidia drivers from rpmfusion installed I have never had any issues at all. (I run the nvidia GPU as primary.)

I only have one nvme drive (only space to have one installed) so I did the normal shrink the windows partition from the windows disk manager and installed fedora in the now available space.

Since grub apparently is managing the boot OK, but gnome is crashing during the initial setup, you should be able to boot to single user mode by editing the grub command line for the boot ( e from the grub menu) and putting the number 1 at the end of the kernel command line (starts with linux). It should then boot to single user run level 1.
Once there run journalctl -b 1 and it should give you the entries for the last boot which can then be analyzed for the crash. That output can be directed to a file which can then be accessed from booting to the live usb system for detailed analysis.

1 Like

Thanks. My Windows 10 laptop is an all AMD offering. The CPU is 5900HX with integrated Radeon graphics, but it also sports a Radeon RX 6800M GPU. It lacks a MUX so controlling which engine is in charge of the display is vexed. I could try using an external HDMI port, which will force the use of GPU in most video game scenarios, but I’m really more bent on Terminal programs.

I’ll try the grub command line and post my results.

journalctl -b 1, it won’t give entries for the last boot. It will show logs of all previous dates including last boot.
journalctl -b, it will give you entries for last boot only.

My mistake. that should have been
journalctl -b -1
to see the entries from the next-to-last boot

Although my grub menu functionality is working, it doesn’t enable me to enter console/rescue mode.

Adding 1 to the end of grub’s linux kernel line and executing produces

You are in rescue mode. After logging in, type “journalctl -xb” to view system logs,
“systemctl reboot” to reboot, “systemctl default” or “exit” to boot into default mode.

Cannot open access to console, the root account is locked. See sulogin(8) man
page for more details.

Press Enter to continue.

That is of course the only option, and it sends me back to the “Welcome” sequence of screens that, in the normal course of installation, would lead to creation of the first user account (with administrative permissions).

While I assume the grub command line is available to me, I don’t know enough to use that by itself to find or repair the installation.

Update: I was able to make it through the startup screens, setting a username and password, by mixing alphanumeric keystrokes with keys like up-arrow that do get into the text fields. The effect is something like the screen going blank with one keystroke and (after delay) coming back after another keystroke. At any rate I can now revisit the grub menu to console approach.

I’ve run out of things to try short of re-installation. The first sign of trouble was the installation itself not running except in “basic graphics” mode. Although I used that to get through installation, it appears the graphical interface wound up in an unusable state.

Keypresses cause the screen to blank out when logging in. Attaching an external monitor does not give any extra information about the underlying problem. The GRUB menu option of single user login as root doesn’t work, even after setting up a user account (same message about root account being locked).

I’m also unable to invoke a console TTY via function keys because the screen crashes there just as with the GNOME login screens.

I’ll sleep on it, but I’m thinking about trying install RHEL 8 with the option to use a basic graphics mode to clarify what drivers might be missing from my F34 installation.

You can try to avoid the problem by using the netinstall image:
Index of /pub/fedora/linux/releases/34/Everything/x86_64/iso
It should also allow you to create a user during installation.