Corsair Device Input Broken by Fedora 38 Upgrade

I upgraded from Fedora 37 to 38 on my desktop computer, where I use Corsair peripherals with the ckb-next project to control the lighting and firmware updates. Normally these devices work out of the box, and they still managed to work for typing in my password to decrypt my drive; however when I got past grub to the GNOME login screen I was not able to move the cursor or press space or any set of key combinations to either type my password or jump out to the TTY to see if that fixes anything.

After rebooting several times, I tried going back to my Fedora 37 install to see if that would fix it, however these became similarly unresponsive. I assumed at first that this was a screen freeze, however after waiting a couple minutes to see if it would unfreeze, however it faded to suspend as usual. I tried accessing the recovery partition; however my root partition was locked, so I installed a Fedora 38 live ISO to chroot into my drive and poke around to see if I could fix it. However when I booted into this I was no more successful inputting anything with my Corsair mouse and keyboard, so this is what made me suspect an input issue. After attaching a wireless USB mouse that I have, I was able to interact with the system.

To debug, I tried installing ckb-next on my laptop which I also upgraded to Fedora 38. At first it did not work, however I ran “sudo systemctl enable ckb-next-daemon && sudo systemctl start ckb-next-daemon” and then it began to work after opening up ckb-next. I was able to use my wireless USB mouse and the on screen keyboard to get the same on the Fedora 38 live ISO, however I’m not really sure how to proceed. I have an extra mouse, but unfortunately I don’t think I have an extra keyboard laying around anywhere, so I don’t believe I would be able to get access to the onscreen keyboard at the lock screen in my current install on my desktop.

I don’t have anything too critical, but I’d prefer not losing access to the files on my current install by using the live ISO to install a fresh Fedora 38 image, and my ckb-next install settings wouldn’t persist through reboot anyway. Am I able to do this by chrooting into my system using the live ISO and if so how would I do that? Does anyone know what could have caused this issue and to have it persist through images to installs of Fedora that previously worked? I don’t believe I needed ckb-next for basic typing and input functionality on previous versions of Fedora or other Linux flavors. Is there somewhere upstream this issue can be reported?

Additionally, ckb-next does not seem to detect any connected devices despite them only working with the setup as described.

EDIT: I confirmed this issue does not present itself in the Ubuntu 23.04 live ISO, so it doesn’t seem like a GNOME 44 or other type of “universal” issue

EDIT 2: I was able to get in to my desktop using the mouse because the accessibility icon at the top of the login screen allowed me to use the on screen keyboard. In GNOME software I received a firmware update for my mouse and it worked fine spontaneously; however, my keyboard is still not working and neither device appears in ckb-next. None of the fixes I have found persist through reboot and it all breaks anew every time. I also had to install multiple terminal emulators from GNOME Software due to the fact that I was unable to run terminal commands, because none of the terminal emulators- aside from Tilix- are recognized as text spaces by the onscreen keyboard (and thus I cannot press enter for commands copied from other text spaces). Once I was able to run commands I ran an update and that did not fix the issue.

EDIT 3: I created a Fedora 37 live ISO and everything works as expected, seems like a Fedora 38-specific regression. Additionally that update pushed to my mouse (somewhat obviously in retrospect) was a phony one that borked my device on operating systems with ckb-next successfully installed. The update was of a greater version number than any firmware version out for the mouse and made the cursor immediately run off the right edge of the screen upon movement. I had to force update the firmware with a Windows device borrowed from a family member, so this seems like something that really should be avoided on Fedora. All is good on non-Fedora 38 systems now.

I guess it is not Fedoras problem when you use Hardware who was optimized to use with a closed source OS like Windows. Fedora uses out of the box Open Source Software and this can bring problems with some Hardware.

As long as this Opensource Drivers not are actualized for newer Kernel versions, the only option is to wait or to make bug requests to solve this problems.

I want to be clear, I have used this hardware out of the box since Fedora 26, with a lot more ease of use than other distros since Fedora actually has packaged the free and open source software ckb-next for controlling the lighting since Fedora 28. In that time I have handled multiple firmware updates using only open source software. Now, in Fedora 38, basic input is broken out of the box and it is pushing faulty firmware updates in the software center that break the device. This is not replicated on other distros with similar technologies, or even Fedora 37. This is a Fedora 38-based regression.

Instated of just complaining bring specs of your system.
Just digging in the dirt not will fix your system.

Devices: Corsair K70 RGB Rapidfire Keyboard and Corsair Katar Pro XT mouse, replicated across multiple hardware systems

I didn’t realize that a newcomer to contributing to Fedora interested in helping report and debug a real world regression in the latest edition of Fedora would be considered “complaining” and be told to simply not use anything that wasn’t designed Linux-first by the manufacturer, I thought someone with a better understanding of Fedora’s components and project infrastructure might be able to point me towards some tests I could run in the command line to better diagnose what component what was causing the issue or what part of the Fedora project I could reach out to report it.

Reddit has helped me through the process of filing a bug report, thank you for your time.

Please post also the link to the bug report!

Here it is:

Libinput seems far too general to create a distinct experience between Ubuntu and Fedora, but it was my best guess at the culprit of an input issue.

Please let me know if you have any constructive criticism to create a better bug report.

Have a look if your hardware is working with an older kernel as a workaround till the new kernel is working.
You can test the LTS kernel kwizart/kernel-longterm-6.1 Copr

You wrote that you use the ckb-next porject as a driver in Linux for your keyboard and mouse?
The kernel changes many times need some fixes/changes in driver that they work fine again. It looks like that the corsair-protocol needs to be reverse engineered, so it might takes a moment till this is fixed.

Just when this is fixed fedora will update the package and it will work also in fedora again.

The ckb-netxt projects contact an chanels are:


Maintainers reserve the rights to modify and remove issues, pull requests and comments therein, that are denunciating, off-topic, harmful, hateful and overall inappropriate. Please be appreciative, humble and kind to each other.

Thanks for the update.

Fedora 38 is running the 6.2.0(-20) kernel right? This is the kernel version of the Kubuntu 23.04 system that I am currently running while this is pending a solution. CKB-Next is working on Kubuntu, which is what makes me lean against saying it is a ckb-next or kernel issue, although I could obviously be wrong. I didn’t want to clog up the ckb-next issues for that reason, but obviously they may know better about what components the Corsair devices interact with that could be causing the issue for Fedora 38. I’m new to reaching out about issues in these circles, so do you think it is still worth reaching out given the above statements? EDIT: Additionally I want to note that ckb-next has been useful for things like lighting patterns and DPI adjustments, but not required for input functionality in the past/other distros.

Additionally, am I able to test this in a live ISO or should I carve out a partition for Fedora 38 for testing purposes?