Conflicting request when trying to upgrade to Fedora 40 branch

I wanted to upgrade my 39 installation to the 40 branch. But I’m stuck on these errors:

Error:
 Problem: conflicting requests
  - package libva-intel-media-driver-24.1.3-1.fc40.i686 from fedora conflicts with intel-media-driver provided by intel-media-driver-24.1.3-1.fc40.x86_64 from rpmfusion-nonfree
  - package libva-intel-media-driver-24.1.3-1.fc40.x86_64 from fedora conflicts with intel-media-driver provided by intel-media-driver-24.1.3-1.fc40.x86_64 from rpmfusion-nonfree
  - package gstreamer1-plugins-bad-free-1.22.9-3.fc40.x86_64 from fedora requires libva.so.2()(64bit), but none of the providers can be installed
  - package vlc-plugin-gstreamer-1:3.0.20-12.fc40.x86_64 from fedora requires gstreamer1-plugins-bad-free(x86-64), but none of the providers can be installed
  - libva-2.20.0-2.fc39.x86_64 from @System  does not belong to a distupgrade repository

I did dnf --refresh upgrade before, I’ve also added --allowerasing --skip-broken to the system-upgrade command.

I don’t understand these errors. I don’t have the first 4 packages installed. Can’t remove libva, since this would remove plasma-desktop.

will be completely honest and hope that it is not offensive. If you can’t understand and can’t solve that upgrade error, my advise is not to upgrade to an unreleased branch of Fedora. As long as Fedora is unreleased this or similar errors may occur and you won’t have any fun.

May I ask you why you need branched (future f40)?

2 Likes

If I don’t do it, I probably won’t understand it and won’t be able to solve it in the future. I’ve tried searching for solutions, but they neither worked nor explained what’s happening.

I want to upgrade, because of the KDE upgrade. There are several bugs in KDE 5 which are a “Won’t fix” on the KDE side, since they are not working on KDE 5 anymore.

We can mentor you in upgrade issue problems.

But please confirm that you are happy to be running experimental code that is likely to break your pc. Are you happy doing this?

3 Likes

Yes, I know what I’m signing up for. I have a backup PC if everything fails.

The first issue is caused by the intel-media-driver from RPM Fusion and the new libva-intel-media-driver from Fedora 40. You may need to uninstall one.

The package libva-2.20.0-2.fc39 is a Fedora 39 package. It should be upgraded to libva-2.20.0-4.fc40. Do you have libavcodec-freeworld or ffmpeg from RPM Fusion installed?

In addition, there is an issue with Fedora 40 Rawhide (I cannot boot my device after 20240130 update:

This is what confuses me. I don’t have intel-media-driver installed (it’s a PC with a nVidia graphics card and no integrated Intel GPU). dnf info intel-media-driver shows 2 packages are “Available” and none “Installed”.

I did also:

$dnf repoquery --whatrequires libva-intel-media-driver --releasever=40
(...)
libigfxcmrt-0:24.1.3-1.fc40.i686
libigfxcmrt-0:24.1.3-1.fc40.x86_64
$dnf repoquery --whatrequires intel-media-driver --releasever=40
(nothing was found)

libigfxcmrt was returned as libigfxcmrt-devel dependency, these packages don’t exist in 39. This is why I’m confused why it reports this as a problem, since I my install shouldn’t really depend on them.

As for libva, I have ffmpeg from RPM Fusion installed but not libavcodec-freeworld.

It works on my VM after dropping group dependencies:

sudo dnf group mark remove gnome-desktop
sudo dnf group mark remove workstation-product-environment

More clues can be found in the debugging output.

The group Multimedia wants to install the package libva-intel-media-driver and not the package intel-media-driver. It might help if you remove intel-media-driver and install libva-intel-media-driver before upgrading.

Bingo. I’m writing this from 40. In my case it was:

sudo dnf group mark remove kde-desktop-environment
sudo dnf group mark remove kde-desktop

After this, the upgrade completed without --allowerasing and --skip-broken.

Thanks for posting the solution. Can you explain what this command does? Do I need to revert this command after upgrading to f40?

It just marks the group as not installed. It won’t remove any packages. You can mark it again after the upgrade. Though dnf group install kde-desktop-environment still fails on Fedora 40 if you have RPM Fusion enabled and gstreamer installed. Here’s the relevant Bug 6861 from RPM Fusion’s Bugzilla.

From Ask Fedora to Project Discussion

Added quality-team and removed f40, intel, upgrades